hdoj5878I Count Two Three【二分】

I Count Two Three

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 115    Accepted Submission(s): 72


Problem Description
I will show you the most popular board game in the Shanghai Ingress Resistance Team.
It all started several months ago.
We found out the home address of the enlightened agent Icount2three and decided to draw him out.
Millions of missiles were detonated, but some of them failed.

After the event, we analysed the laws of failed attacks.
It's interesting that the  i -th attacks failed if and only if  i  can be rewritten as the form of  2a3b5c7d  which  a,b,c,d  are non-negative integers.

At recent dinner parties, we call the integers with the form  2a3b5c7d  "I Count Two Three Numbers".
A related board game with a given positive integer  n  from one agent, asks all participants the smallest "I Count Two Three Number" no smaller than  n .
 

Input
The first line of input contains an integer  t (1t500000) , the number of test cases.  t  test cases follow. Each test case provides one integer  n (1n109) .
 

Output
For each test case, output one line with only one integer corresponding to the shortest "I Count Two Three Number" no smaller than  n .
 

Sample Input
  
  
10 1 11 13 123 1234 12345 123456 1234567 12345678 123456789
 

Sample Output
  
  
1 12 14 125 1250 12348 123480 1234800 12348000 123480000
 

Source
 
#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<queue>
#include<list>
#include<vector>
#include<map>
#include<set>
using namespace std;
typedef long long LL;
typedef pair<int,int>pii;
const int maxn=1000010;
LL num[maxn],cnt;
LL Pow(LL a,LL b){
    LL ans=1ll;
    for(int i=1;i<=b;++i){
        ans*=a;
    }
    return ans;
}
void calu(){
    for(int a=0;a<=31;++a){
        for(int b=0;b<=19;++b){
            for(int c=0;c<=12;++c){
                for(int d=0;d<=12;++d){
                    LL ans=Pow(2ll,a);if(ans>1e9)break;
                    ans*=Pow(3ll,b);if(ans>1e9)break;
                    ans*=Pow(5ll,c);if(ans>1e9)break;
                    ans*=Pow(7ll,d);if(ans>1e9)break;
                    num[cnt++]=ans;
                }
            }
        }
    }
    sort(num,num+cnt);
}
int main()
{
    calu();
    int t;cin>>t;
    while(t--){
        LL n;scanf("%lld",&n);
        int l=0,r=cnt-1,ans;
        while(l<=r){
            int mid=(l+r)>>1;
            if(num[mid]>=n){
                r=mid-1;ans=mid;
            }
            else {
                l=mid+1;
            }
        }
        printf("%lld\n",num[ans]);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值