hdoj5879Cure

54 篇文章 0 订阅

Cure

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 229    Accepted Submission(s): 81


Problem Description
Given an integer  n , we only want to know the sum of  1/k2  where  k  from  1  to  n .
 

Input
There are multiple cases.
For each test case, there is a single line, containing a single positive integer  n
The input file is at most 1M.
 

Output
The required sum, rounded to the fifth digits after the decimal point.
 

Sample Input
  
  
1 2 4 8 15
 

Sample Output
  
  
1.00000 1.25000 1.42361 1.52742 1.58044
 

Source

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<queue>
#include<list>
#include<vector>
#include<map>
#include<set>
using namespace std;
typedef long long LL;
typedef pair<int,int>pii;
const int maxn=1000010;
double ans[maxn];
char s[1000010];
int main()
{
    for(LL i=1;i<=1000000;++i){
        ans[i]=ans[i-1]+1.0/(i*i);
    }
    while(scanf("%s",s)!=EOF){
        int len=strlen(s);
        if(len>=7){
            printf("%.5lf\n",ans[1000000]);
        }
        else {
            int c=0;
            for(int i=0;i<len;++i){
                c=c*10+(s[i]-'0');
            }
            printf("%.5lf\n",ans[c]);
        }
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值