【hdu 3037】Saving Beans

Saving Beans

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2578    Accepted Submission(s): 956


Problem Description
Although winter is far away, squirrels have to work day and night to save beans. They need plenty of food to get through those long cold days. After some time the squirrel family thinks that they have to solve a problem. They suppose that they will save beans in n different trees. However, since the food is not sufficient nowadays, they will get no more than m beans. They want to know that how many ways there are to save no more than m beans (they are the same) in n trees.

Now they turn to you for help, you should give them the answer. The result may be extremely huge; you should output the result modulo p, because squirrels can’t recognize large numbers.
 

Input
The first line contains one integer T, means the number of cases.

Then followed T lines, each line contains three integers n, m, p, means that squirrels will save no more than m same beans in n different trees, 1 <= n, m <= 1000000000, 1 < p < 100000 and p is guaranteed to be a prime. 
 

Output
You should output the answer modulo p.
 

Sample Input
  
  
2 1 2 5 2 1 5
 

Sample Output
  
  
3 3
Hint
Hint For sample 1, squirrels will put no more than 2 beans in one tree. Since trees are different, we can label them as 1, 2 … and so on. The 3 ways are: put no beans, put 1 bean in tree 1 and put 2 beans in tree 1. For sample 2, the 3 ways are: put no beans, put 1 bean in tree 1 and put 1 bean in tree 2.
 

Source

lucas定理模板题。




ans=c(n,1)+c(n+1,2)+....c(n+m-1,m)


根据c(n+1,m)=c(n,m)+c(n,m-1),ans=c(n+m,m)然后套用Lucas模板


#include <iostream>
#include <cstring>
#include <algorithm>
#include <cstdio>
#include <cmath>
#define LL long long
using namespace std;
int T;
LL fac[100005],n,m,p;
LL Powmod(LL a,LL b,LL p)  //费马小定理求逆元
{
	LL ans=1LL,now=a;
	while (b)
	{
		if (b&1) ans=(ans*now)%p;
		b>>=1;
		now=(now*now)%p;
	}
	return ans;
}
LL Lucas(LL n,LL m,LL p)
{
	LL ans=1LL;
	while (n&&m)
	{
		LL a=n%p,b=m%p;
		if (a<b) return 0;
		ans=(ans*fac[a]*Powmod(fac[b]*fac[a-b]%p,p-2,p))%p;
		n/=p;
		m/=p;
	}
	return ans;
}
void Getfact(LL p)
{
	fac[0]=1LL;
	for (int i=1;i<=p;i++)
		fac[i]=(fac[i-1]*(LL)i)%p;
}
int main()
{
    scanf("%d",&T);
    while (T--)
    {
		scanf("%lld%lld%lld",&n,&m,&p);
		Getfact(p);
		printf("%lld\n",Lucas(n+m,m,p));
	}
	return 0;
}



感悟:

Lucas定理就是Lucas(n,m,p)=Lucas(n/p,m/p,p)*C(n%p,m%p)


但是证明的最后一句没看懂!!

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值