HDU2616 Kill the monster(深搜DFS)

题目:

Kill the monster

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1404    Accepted Submission(s): 959


Problem Description
There is a mountain near yifenfei’s hometown. On the mountain lived a big monster. As a hero in hometown, yifenfei wants to kill it. 
Now we know yifenfei have n spells, and the monster have m HP, when HP <= 0 meaning monster be killed. Yifenfei’s spells have different effect if used in different time. now tell you each spells’s effects , expressed (A ,M). A show the spell can cost A HP to monster in the common time. M show that when the monster’s HP <= M, using this spell can get double effect.
 

Input
The input contains multiple test cases.
Each test case include, first two integers n, m (2<n<10, 1<m<10^7), express how many spells yifenfei has.
Next n line , each line express one spell. (Ai, Mi).(0<Ai,Mi<=m).
 

Output
For each test case output one integer that how many spells yifenfei should use at least. If yifenfei can not kill the monster output -1.
 

Sample Input
  
  
3 100 10 20 45 89 5 40 3 100 10 20 45 90 5 40 3 100 10 20 45 84 5 40
 

Sample Output
  
  
3 2 -1
 

Author
yifenfei
 

Source
 

Recommend
yifenfei
 

Statistic |  Submit |  Discuss |  Note
思路:

一个人要打BOSS,他有n个技能,每个技能可以造成不同伤害,针对每一个技能,当BOSS的血量低于这个值时可以触发暴击导致2被伤害,题目问最少需要放几个技能可以打死BOSS,如果技能放完了打不死就输出-1,简单深搜。

代码:

#include <stdio.h>
#include <string.h>
#include <iostream>
#include <stack>
#include <queue>
#include <vector>
#include <cmath>
#include <algorithm>
#define mem(a,b) memset(a,b,sizeof(a))
using namespace std;
int aa[20];//每个技能的伤害量
int mm[20];//低于这这个值可以双倍暴击
int vis[20];//标记
int n,m,step;
void dfs(int num,int s)
{
    if(s>=step)return;//剪枝
    if(num<=0)
    {
        if(s<step)step=s;//更新步数
        return;
    }
    for(int i=0; i<n; i++)
    {
        if(!vis[i])
        {
            vis[i]=1;
            if(num<=mm[i])//判断是否能暴击
                dfs(num-2*aa[i],s+1);
            else
                dfs(num-aa[i],s+1);
            vis[i]=0;
        }
    }
}
int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        step=99;
        mem(vis,0);
        mem(aa,0);
        mem(mm,0);
        for(int i=0; i<n; i++)
            scanf("%d%d",&aa[i],&mm[i]);
        dfs(m,0);
        if(step==99)
            printf("-1\n");
        else
            printf("%d\n",step);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值