POJ-3070Fibonacci(矩阵快速幂)

Description

In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of the Fibonacci sequence are:

0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …

An alternative formula for the Fibonacci sequence is

.

Given an integer n, your goal is to compute the last 4 digits of Fn.

Input

The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.

Output

For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).

Sample Input

0
9
999999999
1000000000
-1

Sample Output

0
34
626
6875

Hint

As a reminder, matrix multiplication is associative, and the product of two 2 × 2 matrices is given by

.

Also, note that raising any 2 × 2 matrix to the 0th power gives the identity matrix:

.


第一次学矩阵快速幂,主要用在递推公式上,能大大的提高运行效率,将MOD增大能做大数。

矩阵的幂题目里有说,代码是实现。

矩阵快速幂复杂度一般是 O(lgn)

跑了0ms

代码如下:

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cstring>
using namespace std;
#define M 10000
struct edg{
	int  m[2][2];
};
edg matlab(edg x,edg y)
{
	edg ans;
    	for(int i=0;i<2;i++)
	       for(int j=0;j<2;j++)
	     {
	  	ans.m[i][j]=0;
		    for(int k=0;k<2;k++)
	            	ans.m[i][j]=(M+x.m[i][k]*y.m[k][j]+ans.m[i][j])%M;
	    }
 	   return ans;
}
int  fast_matlab(int  n)
{
	edg ans,base;
	base.m[0][0]=base.m[0][1]=base.m[1][0]=1;
	base.m[1][1]=0;
    ans.m[0][0]=ans.m[1][1]=1;
    ans.m[1][0]=ans.m[0][1]=0;
	while(n)
	{
		if(n&1)
		ans=matlab(ans,base);
        
		base=matlab(base,base);
		n>>=1;		
    }
	return ans.m[0][1];
}
int main()
{
      	int  a,t,n;
	  	while(cin>>n)
	  	{
	  		if(n==-1) break;
	  		cout<<fast_matlab(n)<<endl;
		  }
      return 0;
} 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值