POJ 3784 Running Median

Description

For this problem, you will write a program that reads in a sequence of 32-bit signed integers. After each odd-indexed value is read, output the median (middle value) of the elements received so far.

Input

The first line of input contains a single integer P, (1 ≤ P ≤ 1000), which is the number of data sets that follow. The first line of each data set contains the data set number, followed by a space, followed by an odd decimal integer M, (1 ≤ M ≤ 9999), giving the total number of signed integers to be processed. The remaining line(s) in the dataset consists of the values, 10 per line, separated by a single space. The last line in the dataset may contain less than 10 values.

Output

For each data set the first line of output contains the data set number, a single space and the number of medians output (which should be one-half the number of input values plus one). The output medians will be on the following lines, 10 per line separated by a single space. The last line may have less than 10 elements, but at least 1 element. There should be no blank lines in the output.

Sample Input

3 
1 9 
1 2 3 4 5 6 7 8 9 
2 9 
9 8 7 6 5 4 3 2 1 
3 23 
23 41 13 22 -3 24 -31 -11 -8 -7 
3 5 103 211 -311 -45 -67 -73 -81 -99 
-33 24 56

Sample Output

1 5
1 2 3 4 5
2 5
9 8 7 6 5
3 12
23 23 22 22 13 3 5 5 3 -3 
-7 -3
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

第一次忘了更新中位数,结果WA了。

然后呢,第二次居然得了个Presentation Error!!

百度了一下,居然是格式错误。。。

不想改了(其实加一个数组记录一下就可以了),下面是没有改的代码。


#include<cstdio>
#include<cstring>
#include<queue>
#include<vector>
#include<algorithm>
using namespace std;

int P,n,m,x,y,k,kk,t;
priority_queue <int> da;  //大根堆(小数) 
priority_queue <int,vector<int>,greater<int> > xiao;  //greater<int>后面必须有空格 

int main()
{
	scanf("%d",&P);
	while(P--)
	{
		while(da.size()) da.pop();
		while(xiao.size()) xiao.pop();
		scanf("%d%d%d",&n,&m,&x);
		kk=(m+1)/2;
		printf("%d %d\n",n,kk);
		xiao.push(x);
		k=x;
		printf("%d",x);
		for(int i=1;i<=kk-1;i++)
		{
			scanf("%d%d",&x,&y);
			if(x<k) da.push(x);
			else xiao.push(x);
			if(y<k) da.push(y);
			else xiao.push(y);
			while(xiao.size()>da.size()+1)
			{
				da.push(xiao.top()); xiao.pop();
			}
			while(xiao.size()<da.size()+1)
			{
				xiao.push(da.top());da.pop();
			}
			k=xiao.top();
			printf(" %d",k);
		}
		printf("\n");
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值