HDU 2256 Problem of Precision 解题报告(矩阵快速幂 + 构造)

96 篇文章 0 订阅

Problem of Precision

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 844    Accepted Submission(s): 489


Problem Description

 

Input
The first line of input gives the number of cases, T. T test cases follow, each on a separate line. Each test case contains one positive integer n. (1 <= n <= 10^9)
 

Output
For each input case, you should output the answer in one line.
 

Sample Input
  
  
3 1 2 5
 

Sample Output
  
  
9 97 841
 

    解题报告: 想了很久,没有思路……看了解题报告

    推理过程如下:


    最终结果表明,中途取模也不会有影响,用矩阵快速幂求的xn即可。代码如下

#include <cstdio>
#include <cstring>
#include <map>
#include <cmath>
#include <algorithm>
using namespace std;

const int mod=1024;

struct Matrix
{
    int a[2][2];
    Matrix(int t=0)
    {
        memset(a, 0, sizeof(a));
        a[0][0]=a[1][1]=t;
    }

    Matrix operator*(const Matrix& cmp) const
    {
        Matrix c;
        for(int i=0;i<2;i++) for(int j=0;j<2;j++)
        {
            long long t=0;
            for(int k=0;k<2;k++) t+=a[i][k]*cmp.a[k][j];
            c.a[i][j]=t%mod;
        }
        return c;
    }
} p;

Matrix powM(Matrix a, int b)
{
    Matrix res(1);
    while(b)
    {
        if(b&1)
            res=res*a;
        a=a*a;
        b>>=1;
    }
    return res;
}

int main()
{
    p.a[0][0]=5;
    p.a[0][1]=2;
    p.a[1][0]=12;
    p.a[1][1]=5;

    int T;
    scanf("%d", &T);
    while(T--)
    {
        int n;
        scanf("%d", &n);

        Matrix r = powM(p, n-1);
        int res = 2*(5*r.a[0][0]+2*r.a[1][0])-1;
        printf("%d\n", res%mod);
    }
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值