POJ 2664 Prerequisites?(我的水题之路——选课)

Prerequisites?
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 3063 Accepted: 1931

Description

Freddie the frosh has chosen to take k courses. To meet the degree requirements, he must take courses from each of several categories. Can you assure Freddie that he will graduate, based on his course selection?

Input

Input consists of several test cases. For each case, the first line of input contains 1 <= k <= 100, the number of courses Freddie has chosen, and 0 <= m <= 100, the number of categories. One or more lines follow containing k 4-digit integers follow; each is the number of a course selected by Freddie. Each category is represented by a line containing 1 <= c <= 100, the number of courses in the category, 0 <= r <= c, the minimum number of courses from the category that must be taken, and the c course numbers in the category. Each course number is a 4-digit integer. The same course may fulfil several category requirements. Freddie's selections, and the course numbers in any particular category, are distinct. A line containing 0 follows the last test case.

Output

For each test case, output a line containing "yes" if Freddie's course selection meets the degree requirements; otherwise output "no".

Sample Input

3 2
0123 9876 2222
2 1 8888 2222
3 2 9876 2222 7654 
3 2
0123 9876 2222
2 2 8888 2222
3 2 7654 9876 2222
0

Sample Output

yes
no

Source


每一个人毕业需要选课,他已经选了k门课程,现在该专业有m个课程类别,每个类别有c个课程,最少需要选择r门课程才可以毕业,以及该类别下课程的号码列表。如果每个类别,均已经选择了至少r门课程,则可以毕业输出“yes”,否则输出“no”。

将已经选择的课程标记下来,然后对于每一个类别分别进行验证是否已经符合了要求。

注意点:
1)每一个类别要分开统计是否达标,不能混淆(1WA)。

代码(1AC 1WA):
#include <cstdio>
#include <cstdlib>
#include <cstring>

int arr[10010];

int main(void){
    int k, c;
    int num, need, tmp, taken;
    int flag;
    int i, j;

    while (scanf("%d", &k), k != 0){
        memset(arr, 0, sizeof(arr));
        scanf("%d", &c);
        for (i = 0; i < k; i++){
            scanf("%d", &tmp);
            arr[tmp] = 1;
        }
        flag = 1;
        for (i = 0; i < c; i++){
            scanf("%d%d", &num, &need);
            for (j = taken = 0; j < num; j++){
                scanf("%d", &tmp);
                if (arr[tmp] == 1){
                    taken ++;
                }
            }
            if (taken < need){
                flag = 0;
            }
        }
        if (flag){
            printf("yes\n");
        }
        else{
            printf("no\n");
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值