南阳oj 题目122 Triangular Sums

Triangular Sums

时间限制: 3000 ms  |  内存限制: 65535 KB
难度: 2
描述

The nth Triangular number, T(n) = 1 + … + n, is the sum of the first n integers. It is the number of points in a triangular array with n points on side. For example T(4):

X
X X
X X X
X X X X

Write a program to compute the weighted sum of triangular numbers:

W(n) = SUM[k = 1…nk * T(k + 1)]

输入
The first line of input contains a single integer N, (1 ≤ N ≤ 1000) which is the number of datasets that follow.

Each dataset consists of a single line of input containing a single integer n, (1 ≤ n ≤300), which is the number of points on a side of the triangle.
输出
For each dataset, output on a single line the dataset number (1 through N), a blank, the value of n for the dataset, a blank, and the weighted sum ,W(n), of triangular numbers for n.
样例输入
4
3
4
5
10
样例输出
1 3 45
2 4 105
3 5 210
4 10 2145

注:此题为:南阳oj 题目122 Triangular Sums

说明:公式代入:T(n) = 1 + … + n

                        W(n) = SUM[k = 1…nk * T(k + 1)]

            注意输出格式

已AC源代码:

#include<iostream>
using namespace std;
int T_n(int k)
{
	int tn=0,i;
	for(i=1;i<=k;++i)
    	tn+=i;
    	return tn;
}
int main()
{
	int N,temp=1;
	cin>>N;
	while(N--)
	{
		int n,i,Wn,Tn,sum;
		cin>>n;
		sum=0;
		for(i=1;i<=n;++i)
		{
			Tn=T_n(i+1);
			Wn=i*Tn;
			sum+=Wn;
		}
		cout<<temp++<<" "<<n<<" "<<sum<<endl;
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值