POJ 3086 Triangular Sums

Triangular Sums
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 6371 Accepted: 4529

Description

The nth Triangular number, T(n) = 1 + … + n, is the sum of the first n integers. It is the number of points in a triangular array with n points on side. For example T(4):

X
X X
X X X
X X X X

Write a program to compute the weighted sum of triangular numbers:

W(n) = SUM[k = 1…nk * T(k + 1)]

Input

The first line of input contains a single integer N, (1 ≤ N ≤ 1000) which is the number of datasets that follow.

Each dataset consists of a single line of input containing a single integer n, (1 ≤ n ≤300), which is the number of points on a side of the triangle.

Output

For each dataset, output on a single line the dataset number (1 through N), a blank, the value of n for the dataset, a blank, and the weighted sum ,W(n), of triangular numbers for n.

Sample Input

4
3
4
5
10

Sample Output

1 3 45
2 4 105
3 5 210
4 10 2145

Source

找规律的一道题,其实题目已经说的很明白了。
先打表再输出,开始怕时限,所以一直改不对,干脆分开算。
代码:
#include <iostream>
#include <algorithm>
#include <stdio.h>
using namespace std;
int f[305],T[305],sum[305];
int main()
{
    int i,j,n,m;
    T[1]=1;f[1]=1;
    for(i=2;i<305;i++)
    T[i]=i+T[i-1];
    for(i=1;i<304;i++)
    f[i]=i*T[i+1];
    sum[1]=f[1];
    for(i=2;i<305;i++)
    sum[i]=sum[i-1]+f[i];
    while(scanf("%d",&n)!=EOF&&n)
    {
        for(i=1;i<=n;i++)
        {
            scanf("%d",&m);
            printf("%d %d %d\n",i,m,sum[m]);
        }
    }
    return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值