UVa 757 - Gone Fishing

【题目链接】

http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&category=113&page=show_problem&problem=698



【原题】

John is going on a fishing trip. He has h hours available ( $1 \leŸ h \leŸ 16$), and there are n lakes in the area ( $2 \leŸ n \leŸ 25$) all reachable along a single, one-way road. John starts at lake 1, but he can finish at any lake he wants. He can only travel from one lake to the next one, but he does not have to stop at any lake unless he wishes to. For each $i = 1, \dots, n- 1$, the number of 5-minute intervals it takes to travel from lake i to lake i + 1 is denoted ti ( $0 < t_i \leŸ 192$). For example, t3 = 4 means that it takes 20 minutes to travel from lake 3 to lake 4.


To help plan his fishing trip, John has gathered some information about the lakes. For each lake i, the number of fish expected to be caught in the initial 5 minutes, denoted fi ( $f_i \ge– 0$), is known. Each 5 minutes of fishing decreases the number of fish expected to be caught in the next 5-minute interval by a constant rate of di ( $d_i \ge– 0$). If the number of fish expected to be caught in an interval is less than or equal to di, there will be no more fish left in the lake in the next interval. To simplify the planning, John assumes that no one else will be fishing at the lakes to affect the number of fish he expects to catch.


Write a program to help John plan his fishing trip to maximize the number of fish expected to be caught. The number of minutes spent at each lake must be a multiple of 5.

Input 

You will be given a number of cases in the input. Each case starts with a line containing  n . This is followed by a line containing  h . Next, there is a line of  n  integers specifying  f i  (  $1 \leŸ i \leŸ n$ ), then a line of  n  integers  d i  (  $1 \leŸ i \leŸ n$ ), and finally, a line of  n  - 1 integers  t i  (  $1 \leŸ i Ÿ\le n - 1$ ). Input is terminated by a case in which  n  = 0.

Output 

For each test case, print the number of minutes spent at each lake, separated by commas, for the plan achieving the maximum number of fish expected to be caught (you should print the entire plan on one line even if it exceeds 80 characters). This is followed by a line containing the number of fish expected. If multiple plans exist, choose the one that spends as long as possible at lake 1, even if no fish are expected to be caught in some intervals. If there is still a tie, choose the one that spends as long as possible at lake 2, and so on. Insert a blank line between cases.

Sample Input 

2
1
10 1
2 5
2
4
4
10 15 20 17
0 3 4 3
1 2 3
4
4
10 15 50 30
0 3 4 3
1 2 3
0

Sample Output 

45, 5
Number of fish expected: 31

240, 0, 0, 0
Number of fish expected: 480

115, 10, 50, 35
Number of fish expected: 724


【分析与总结】

超级经典的一道贪心题,LRJ黑书上贪心章节的第一道例题。



我是用堆来实现的。


【代码】

/*
 * UVa: 757 - Gone Fishing
 * Greedy
 * Time: 0.044s(UVa), 79MS(poj)
 * Author: D_Double
 *
 */
#include<iostream>
#include<cstring>
#include<cstdio>
#include<queue>
#define MAXN 30
using namespace std;
int h,n;
int ans[MAXN], tmp[MAXN];

struct Node{
    int no;        // 第几号湖
    int rate;      // 每5分钟钓的鱼
    int down;      // 每5分钟减少的钓鱼数量
    int time;      // 从第一个湖走到当前这个湖的时间
    friend bool operator < (const Node&a,const Node&b){
        if(a.rate!=b.rate)
            return a.rate<b.rate;
        return a.no>b.no; // 如果每5分钟钓的鱼相同,优先序号钓小的湖
    }
}arr[MAXN];

priority_queue<Node>que;

void greedy(){
    int maxSum=-10000;
    for(int i=0; i<n; ++i){ // 枚举钓1~i个湖的情况
        while(!que.empty()) que.pop();
        for(int j=0; j<=i; ++j) que.push(arr[j]);

        int leftTime=h*60-arr[i].time, sum=0;
        memset(tmp, 0, sizeof(tmp));

        while(leftTime > 0){
            Node temp=que.top();
            que.pop();
            if(temp.rate<=0) break;
            sum += temp.rate;
            temp.rate -= temp.down;
            tmp[temp.no] += 5;
            que.push(temp);
            leftTime -= 5;
        }  
        if(leftTime>0) tmp[0] += leftTime; // 注意把剩下的时间都加到第一个湖上
        if(sum > maxSum){
            maxSum=sum;
            for(int j=0; j<n; ++j)
                ans[j]=tmp[j];
        }
    }
    printf("%d",ans[0]);
    for(int i=1; i<n; ++i)
        printf(", %d",ans[i]);
    printf("\n");
    printf("Number of fish expected: %d\n", maxSum);
}


int main(){
    bool flag=false;
    while(~scanf("%d",&n)&&n){
        scanf("%d",&h);
        for(int i=0; i<n; ++i){
            scanf("%d",&arr[i].rate);
            arr[i].no = i;
        }
        for(int i=0; i<n; ++i){
            scanf("%d",&arr[i].down);
        }
        arr[0].time=0;
        for(int i=1; i<=n-1; ++i){
            int t;
            scanf("%d",&t);
            arr[i].time = arr[i-1].time+t*5;
        }
        if(flag)printf("\n");
        else flag=true;
        greedy(); 
    }
    return 0;
}


——  生命的意义,在于赋予它意义。

          
     原创 http://blog.csdn.net/shuangde800 , By   D_Double  (转载请标明)



  • 3
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值