HDOJ 1003 Max Sum(DP,思维)

Max Sum

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 216774    Accepted Submission(s): 51095


Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
 

Sample Input
  
  
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
 

Sample Output
  
  
Case 1: 14 1 4 Case 2: 7 1 6
 

Author
Ignatius.L
 

Recommend
We have carefully selected several similar problems for you:   1176  1087  1069  1058  1159 
 


思路1:

看注释部分。


代码:(没用DP)

#include<stdio.h>
const int MYDD=1103;

int main() {
	int t;
	scanf("%d",&t);
	int Kcase=0;
	while(Kcase!=t) {
		int n,ans,max,began,T,end;
		scanf("%d",&n);
		ans=-(int)1e10;//答案初始化
		max=0;//局部的最大值
		T=1;//局部最大值的开始项
		int temp;
		for(int j=1; j<=n; j++) {
			scanf("%d",&temp);
			if(max>=0) {
				max+=temp;
			} else {
				max=temp;
				T=j;
			}
//			printf("****T %d*******%d\n",T,began);
			if(max>ans) {
				ans=max;
				began=T;
				end=j;
			}
		}
		printf("Case %d:\n",Kcase+1);
		printf("%d %d %d\n",ans,began,end);
		Kcase++;
		if(Kcase!=t)	printf("\n");
	}
	return 0;
}


思路2:利用动态规划,坑人的地方在输出格式,也要输出开始点和结束点:

代码:

#include<stdio.h>
#include<string.h>
const int MYDD=1e5+1103;

int a[MYDD];
int MAX(int x,int y) {
	return x>y? x:y;
}

int main() {
	int t;
	scanf("%d",&t);
	for(int i=1; i<=t; i++) {
		int n,dp=0;
		scanf("%d",&n);
		for(int j=0; j<n; j++)
			scanf("%d",&a[j]);

		int strat=0,end=0,max=-1e10,temp=0;
		for(int j=0; j<n; j++) {
			dp+=a[j];
			if(dp>max) {//坑人的输出方式 
				max=dp;
				strat=temp;
				end=j;//记录终点位置
			}
			if(dp<0) {
				dp=0;
				temp=j+1;
			}
		}

		printf("Case %d:\n",i);
		printf("%d %d %d\n",max,strat+1,end+1);
		if(i!=t)	printf("\n");
	}
	return 0;
}
/*

9
2 -5689 9
9 2 2
*/

格式一直改不对的代码:

#include<stdio.h>
#include<string.h>
const int MYDD=1e5+1103;

int a[MYDD],dp[MYDD];
int MAX(int x,int y) {
    return x>y? x:y;
}

int main() {
    int t;
    scanf("%d",&t);
    for(int i=1; i<=t; i++) {
        memset(dp,0,sizeof(dp));
        int n;
        scanf("%d",&n);
        for(int j=0; j<n; j++)
            scanf("%d",&a[j]);

//        if(n==1) {
//            printf("Case %d:\n",i);
//            printf("%d %d %d\n",a[0],1,1);
//            continue;
//        }

        int strat,end,max,k=0;
        dp[0]=max=a[0];
        for(int j=1; j<n; j++) {
            dp[j]=MAX(dp[j-1]+a[j],a[j]);//进行动态规划求解
            if(max<dp[j]) {
                max=dp[j];
                end=j;//记录终点位置 
            }
        }

        int tsum=0;//找到起始位置
        for(int j=end; j>=0; j--) {
            tsum+=a[j];
            if(tsum==max)        strat=j;
        }
        
        printf("Case %d:\n",i);
        printf("%d %d %d\n",max,strat+1,end+1);
        if(i!=t)    printf("\n");
    }
    return 0;
}
/*

9
2 -5689 9
9 2 2
*/

后:

********************


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值