hdoj1003 java_DP(一)HDOJ 1003 Max Sum(java版)

题目链接:点我一下

题目:

Given a sequence a[1],a[2],a[3]……a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.

输入:

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).

输出

For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.

示例输入:

2

5 6 -1 5 4 -7

7 0 6 -1 1 -6 7 -5

示例输出:

Case 1:

14 1 4

Case 2:

7 1 6

思路:

比较简单的dp,很容易推出状态转移方程:sum[i] = max{sum[i-1]+a[i],a[i]}. (sum[i]记录以a[i]为子序列末端的最大连续和.)

然后用一个值记录更新sum[i]的最大值即可。

即对于a[i]这个数字,我们考虑是否将它选入之前连续的序列。

如果选,状态变为sum[i-1]+a[i] ; 如果不选,则从此开始一个新的序列,故和为a[i]。

理解方程后,代码很好写了。

代码:

import java.util.*;

public class Main{

public static void main(String[] args) {

int T = 0 , i = 0, j = 0;

Scanner cin = new Scanner(System.in);

T = cin.nextInt();

for(i=1;i<=T;i++) {

int n = 0;

int temp = -1001, ans = -1001, s = 0, e = 0, ss = 0, ee = 0;

n = cin.nextInt();

for(j=1;j<=n;j++) {

int t = cin.nextInt();

if(temp + t < t) {

temp = t;

s = e = j;

}

else {

temp += t;

e++;

}

if(ans < temp) {

ans = temp;

ss = s;

ee = e;

}

}

System.out.println("Case " + i + ":");

System.out.println(ans + " " + ss + " " + ee);

if(i != T) {

System.out.println();

}

}

}

}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值