1094. The Largest Generation (25)

1094. The Largest Generation (25)

时间限制
200 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

A family hierarchy is usually presented by a pedigree tree where all the nodes on the same level belong to the same generation. Your task is to find the generation with the largest population.

Input Specification:

Each input file contains one test case. Each case starts with two positive integers N (<100) which is the total number of family members in the tree (and hence assume that all the members are numbered from 01 to N), and M (<N) which is the number of family members who have children. Then M lines follow, each contains the information of a family member in the following format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a family member, K (>0) is the number of his/her children, followed by a sequence of two-digit ID's of his/her children. For the sake of simplicity, let us fix the root ID to be 01. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the largest population number and the level of the corresponding generation. It is assumed that such a generation is unique, and the root level is defined to be 1.

Sample Input:
23 13
21 1 23
01 4 03 02 04 05
03 3 06 07 08
06 2 12 13
13 1 21
08 2 15 16
02 2 09 10
11 2 19 20
17 1 22
05 1 11
07 1 14
09 1 17
10 1 18
Sample Output:
9 4
     发现这道其貌不扬的题目是上次PAT甲级的原题,然后就大发慈悲重新写了一下,上次做的时候我还不会用stl,这次写起来稍微简练一点了。给你一张图,标出了一个家族内部孩子和父亲的关系,然后希望你找出人数最多的一代,很容易想到广度优先搜索,然后统计每一层的人数。找出最大值。找出最大值最便捷的方式是使用priority_que。
     更简单的方法是把这个看成一张图,直接使用Floyd算法找出各个节点到根节点的个数。不过我没有试过,不知道会不会超时。之后扫一遍统计个数就好了。
# include <cstdio>
# include <queue>
# include <vector>
using namespace std;

const int size = 100;

vector<int> v[size];
typedef pair<int,int> sum_log;
priority_queue<sum_log> pri_que; /*in order to find the max one*/

void bfs(int root)
{
  queue<int> que;
  int i = 1,j;
  que.push(root);
  while (!que.empty())
    {
	  queue<int> tmp;
	  pri_que.push(sum_log(que.size(),i++));
	  while (!que.empty())
	    {
	      int loca = que.front();que.pop();
		  for (j=0;j<v[loca].size();j++)
		      tmp.push(v[loca][j]);  
		}
      que = tmp;
	}
}
int main()
{
  int i,j,k,tmp;
  int n,m;
  scanf("%d%d",&n,&m);
  while (m--)
    {
      scanf("%d%d",&i,&j);
      while (j--)
        {
	      scanf("%d",&k);
	      v[i].push_back(k);
	    }
	}
  bfs(1);
  sum_log ans = pri_que.top();
  printf("%d %d\n",ans.first,ans.second);
  return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值