HDU1950-Bridging signals-最长上升子序列

Description

'Oh no, they've done it again', cries the chief designer at the Waferland chip factory. Once more the routing designers have screwed up completely, making the signals on the chip connecting the ports of two functional blocks cross each other all over the place. At this late stage of the process, it is too 
expensive to redo the routing. Instead, the engineers have to bridge the signals, using the third dimension, so that no two signals cross. However, bridging is a complicated operation, and thus it is desirable to bridge as few signals as possible. The call for a computer program that finds the maximum number of signals which may be connected on the silicon surface without rossing each other, is imminent. Bearing in mind that there may be housands of signal ports at the boundary of a functional block, the problem asks quite a lot of the programmer. Are you up to the task? 

Figure 1. To the left: The two blocks' ports and their signal mapping (4,2,6,3,1,5). To the right: At most three signals may be routed on the silicon surface without crossing each other. The dashed signals must be bridged. 

A typical situation is schematically depicted in figure 1. The ports of the two functional blocks are numbered from 1 to p, from top to bottom. The signal mapping is described by a permutation of the numbers 1 to p in the form of a list of p unique numbers in the range 1 to p, in which the i:th number pecifies which port on the right side should be connected to the i:th port on the left side. 
Two signals cross if and only if the straight lines connecting the two ports of each pair do.
 

Input

On the first line of the input, there is a single positive integer n, telling the number of test scenarios to follow. Each test scenario begins with a line containing a single positive integer p<40000, the number of ports on the two functional blocks. Then follow p lines, describing the signal mapping: On the i:th line is the port number of the block on the right side which should be connected to the i:th port of the block on the left side.
 

Output

For each test scenario, output one line containing the maximum number of signals which may be routed on the silicon surface without crossing each other.
 

Sample Input

    
    
4 6
4 2 6 3 1 5 10 
2 3 4 5 6 7 8 9 10 1 8 
8 7 6 5 4 3 2 1 9 
5 8 9 2 3 1 7 4 6
 

Sample Output

    
    
3 9 1 4
 
题目本质::求最长上升子序列(这里没有重复数字)。

我们有两种思路求可以参考shuoj上的D序列的题目。这里给出题目的题解链接::shuojD序列

主要是两种思路::(1)lower_bound(2)二分法,如果觉得代码不易理解可以点上面的链接

两种方法的思路是一样的。将数组A中子序列长度为 i 的最小值存放在数组S中。我们以3 2 4 6  5 7 3 为例进行演示行为遍历,列为数组S,变化的地方已经标出 来,有助于理解。在这里a[ i ] > s[ j ]&&a[i]<=s[ j + 1 ]就应该把a[ i ]放在s[ j+1 ]的位置。所以关键就是找出 j 就知道把a[ i ]放在哪了。上面的两种方法就是用来寻找 j 的 。(在这里lower_bound直接返回 j + 1 ) 
我们可以发现s数组中的值必然是有序递增的,这也是可以利用二分法的一个必要条件。

演示
01234
13   
22   
324  
4246 
5245 
62457
72357
     

这里给出第二种方法代码::

#include <iostream>
#include<cstring>
#include <algorithm>
#define INF 0x3f3f3f3f
using namespace std;
const int N = 1e5 + 5;
int s[N];
int n,p,a[N];
int len;
int main()
{
	cin>>n;
	while(n--){
		cin>>p;
		memset(s,0,sizeof(s));
		for(int i = 0;i<p;i++)cin>>a[i];
		s[1] = a[0];len = 1;//长度从1开始
		for(int i = 1;i<p;i++){

			int t = a[i];
			if(t>s[len])s[++len] = a[i];
			else{
		/*************/int l = 1,r = len,mid;//这里的二分法采用了左闭右闭的思路
               <span style="white-space:pre">			</span>int ans = 0;
				while(l<=r)
				{
					mid = (l+r)/2;
					if(s[mid]<t)
                        {l = mid +1;ans = max(ans,mid);}//ans即为思路中的j,j必然为s数组中小于t的最大的数
					else r = mid-1;
				}
				s[ans+1] = t;/******************/
			}
		}
		//for(int i = 1;i<p;i++){cout<<s[i];}//有必要可以打开看看s中存的是什么值
		cout<<len<<endl;
	}
	return 0;
}
如果代码不易理解请点击链接,链接为:: shuoj—D序列

第一种的代码只要将两个/**************/之间的代码换为

int p = lower_bound(s+1,s+len+1,t)-s;
s[p] = t;
就可以了。
  • 2
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值