优先队列的使用方法+OJ案例讲解

今天也是第一次尝试着使用了优先队列来做题
其实很早就学过优先队列,但是一直处于的是理论阶段,并没有实际的利用过。

百度百科上的解释是:
优先队列(priority queue)
普通的队列是一种先进先出的数据结构,元素在队列尾追加,而从队列头删除。在优先队列中,元素被赋予优先级。当访问元素时,具有最高优先级的元素最先删除。优先队列具有最高级先出 (first in, largest out)的行为特征。

优先队列在头文件#include <queue>中;

其声明格式为:priority_queue <int> ans;//声明一个名为ans的整形的优先队列

基本操作有:

empty( )  //判断一个队列是否为空

pop( )  //删除队顶元素

push( )  //加入一个元素

size( )  //返回优先队列中拥有的元素个数

top( )  //返回优先队列的队顶元素


优先队列的时间复杂度为O(logn),n为队列中元素的个数,其存取都需要时间。


在默认的优先队列中,优先级最高的先出队。默认的int类型的优先队列中先出队的为队列中较大的数。


其实也就是给普通的队列一个优先级,然后在取元素的时候,我们按照优先级的高低来取元素。
因为接触不是很深,这里我对一种优先队列优先级设置进行我自己理解的讲解


以一个使用到优先队列的题目为例:
                                                                                   Stones                    
Because of the wrong status of the bicycle, Sempr begin to walk east to west every morning and walk back every evening. Walking may cause a little tired, so Sempr always play some games this time.
There are many stones on the road, when he meet a stone, he will throw it ahead as far as possible if it is the odd stone he meet, or leave it where it was if it is the even stone. Now give you some informations about the stones on the road, you are to tell me the distance from the start point to the farthest stone after Sempr walk by. Please pay attention that if two or more stones stay at the same position, you will meet the larger one(the one with the smallest Di, as described in the Input) first.

Input
In the first line, there is an Integer T(1<=T<=10), which means the test cases in the input file. Then followed by T test cases.
For each test case, I will give you an Integer N(0<N<=100,000) in the first line, which means the number of stones on the road. Then followed by N lines and there are two integers Pi(0<=Pi<=100,000) and Di(0<=Di<=1,000) in the line, which means the position of the i-th stone and how far Sempr can throw it.

Output
Just output one line for one test case, as described in the Description.
Sample Input
2
2
1 5
2 4
2
1 5
6 6
Sample Output
11
12


题目大意为:
  1. /*路上有很多石头,当你遇到奇数序列的石头就把他向前仍,偶数的不动,两个石头一起,先考虑扔的距离比较小的石头,这样一直下去,直到前面所有的石头都不可以扔了为止,求最远的石头距离起点多少!! 
  2. 题目这题用优先队列非常方便 
  3. */   
比如说,在给出的案例中,第二个案例的12是这么来的: 第一次我碰到了位置为1能扔5距离远的石头,我把它扔出去,这个石头就变成了位置为6能扔5距离的石头,
接下来我走到了位置为6的地方,有两个石头,根据题意,我先遇见能仍5距离的石头,再遇见能扔6距离的石头,所以第二次遇见的石头不管他,第三次遇见的石头将其扔出去位置从6变成了12,第四次又碰到这个石头不管他,然后之后的路程里就不会再有石头了。结果便输出12。

这个题用优先队列来求,非常的简单,直接套模板就能AC了
就代码来解释理解下所谓的优先队列
代码如下:

#include<cstdio>
#include<iostream>
#include<stack>
#include<map>
#include<cstring>
#include<queue>
using namespace std ;
struct stone{//这是一种自定义设置优先队列优先级的方法,重载默认的 < 符号
    int p;
    int d;
    friend bool operator< (stone a,stone b){
        if(a.p==b.p)
            return a.d>b.d;/*注意这里的比较,这是写的数据越小优先级越高,即先取出数值小的元素其实也可以这么理解,队列我们是可以用数组来存储的,比较sort函数里我们写的cmp ,return a>b时 是按降序来排列的,eg :6 5 4 3 2 1,因为队列又是满足先进先出的原则,所以我们首先取出的是1,也就是数值最小的那个*/
        return a.p>b.p;
    }
};
int main()  {
    int t;
    scanf("%d",&t);
    while(t--){
        int n;
        priority_queue<stone> st; 
       scanf("%d",&n);
       stone t;
       for(int i=0;i<n;i++){
        scanf("%d %d",&t.p,&t.d);
        st.push(t);
       }
       int cou=0;
       stone tp;
       while(!st.empty()){
            tp=st.top();
            st.pop();
            if(++cou&1){
            tp.p+=tp.d;
            st.push(tp);
            }
       }
       printf("%d\n",tp.p);

//代码其它的地方都还是很好理解的.

    }
    return 0 ;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值