POJ 2833 The Average(nlogn排序)

The Average
Time Limit: 6000MS Memory Limit: 10000K
Total Submissions: 9395 Accepted: 2927
Case Time Limit: 4000MS

Description

In a speech contest, when a contestant finishes his speech, the judges will then grade his performance. The staff remove the highest grade and the lowest grade and compute the average of the rest as the contestant’s final grade. This is an easy problem because usually there are only several judges.

Let’s consider a generalized form of the problem above. Given n positive integers, remove the greatest n1 ones and the least n2 ones, and compute the average of the rest.

Input

The input consists of several test cases. Each test case consists two lines. The first line contains three integers n1n2 and n (1 ≤ n1n2 ≤ 10, n1 + n2 < n ≤ 5,000,000) separate by a single space. The second line contains n positive integers ai (1 ≤ ai ≤ 108 for all i s.t. 1 ≤ i ≤ n) separated by a single space. The last test case is followed by three zeroes.

Output

For each test case, output the average rounded to six digits after decimal point in a separate line.

Sample Input

1 2 5
1 2 3 4 5
4 2 10
2121187 902 485 531 843 582 652 926 220 155
0 0 0

Sample Output

3.500000
562.500000

Hint

This problem has very large input data. scanf and printf are recommended for C++ I/O.

The memory limit might not allow you to store everything in the memory.

Source


已知几个数,去掉几个最大值、几个最小值,求平均值。

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <string>
#include <sstream>
#include <vector>
#include <queue>
#include <set>
#include <map>
#include <ctime>
using namespace std;
typedef long long LL;
int cmp(int a, int b)  
{  
    return a>b;  
}  

int main()
{

	LL n1,n2,n;
	while(scanf("%I64d%I64d%I64d",&n1,&n2,&n)!=EOF){
		if(n1 == 0 && n2 == 0 && n == 0)break;
		int h[11],l[11];
		int i = 0;
		for(i = 0;i<11;i++){
			h[i] = 0;
			l[i] = 1e8+1;	
		}

		LL sum = 0;
		for(i = 0;i<n;i++){
			LL num;
			scanf("%I64d",&num);
			sum+=num;
			if(num > h[n1]){
				h[n1] = num;
				sort(h,h+n1+1,cmp);
			}
			if(num < l[n2]){
				l[n2] = num;
				sort(l,l+n2+1);
			}
			
		}
	
		LL n3 = n - n1 - n2;
//		for(i = 0;i<n;i++){
//			cout<<v[i]<<endl;
//		}
		for(i = 0;i<n1;i++){
	//		cout<<h[i]<<endl;
		sum = sum - h[i];
		}
		
		for(i = 0;i<n2;i++){
	//		cout<<l[i]<<endl;
		sum = sum - l[i];
		}
		
//cout<<sum<<endl;
	printf("%.6lf\n",1.0*sum/n3);
   
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值