HDU 1007 Quoit Design(最近点对问题)

Quoit Design

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 59043    Accepted Submission(s): 15645

Problem Description
Have you ever played quoit in a playground? Quoit is a game in which flat rings are pitched at some toys, with all the toys encircled awarded.
In the field of Cyberground, the position of each toy is fixed, and the ring is carefully designed so it can only encircle one toy at a time. On the other hand, to make the game look more attractive, the ring is designed to have the largest radius. Given a configuration of the field, you are supposed to find the radius of such a ring.

Assume that all the toys are points on a plane. A point is encircled by the ring if the distance between the point and the center of the ring is strictly less than the radius of the ring. If two toys are placed at the same point, the radius of the ring is considered to be 0.
 
Input
The input consists of several test cases. For each case, the first line contains an integer N (2 <= N <= 100,000), the total number of toys in the field. Then N lines follow, each contains a pair of (x, y) which are the coordinates of a toy. The input is terminated by N = 0.
 
Output
For each test case, print in one line the radius of the ring required by the Cyberground manager, accurate up to 2 decimal places.
 
Sample Input
 
 
2
0 0
1 1
2
1 1
1 1
3
-1.5 0
0 0
0 1.5
0
Sample Output
 
 
0.71
0.00
0.75

思路:

 
1.题目意思是求任意两点间的最小距离,首先想到的是穷举法。但是穷举法算法复杂度为n的平方,显然会超时的。
2.想到先排序,按x从小到大排序后计算相邻两点的距离,按y从小到大排序后计算相邻两点的距离。最短距离肯定在这些情况中。
3.也可以用分治思想,每次把这些点分成左右两部分,左右各找一点,计算距离。

#include <iostream>
#include <math.h>
#include <stdio.h>
#include <algorithm>
using namespace std;
struct m {
    double x;
    double y;
} a[100001];
double juli(int i,int j) {
    double ans=sqrt(pow(a[i].x-a[j].x,2)+pow(a[i].y-a[j].y,2));
    return ans;
}
bool cmp1(const m a,m b) {
    if(a.x<b.x)
        return true;
    if(a.x>b.x)
        return false;
    else return a.y<b.y;
}
bool cmp2(const m a,m b) {
    if(a.y<b.y)
        return true;
    if(a.y>b.y)
        return false;
    else
        return a.x<b.x;
}
int main() {
    int n;
    while(scanf("%d",&n)!=EOF&&n) {

        for(int i=0; i<n; i++) {
            scanf("%lf%lf",&a[i].x,&a[i].y);
        }
        sort(a,a+n,cmp1);
        double radius=juli(0,1);
        for(int i=1; i<n-1; i++) {
            if(radius>juli(i,i+1))
                radius=juli(i,i+1);
        }
        sort(a,a+n,cmp2);
        for(int i=1; i<n-1; i++) {
            if(radius>juli(i,i+1))
                radius=juli(i,i+1);
        }
        printf("%.2lf\n",radius/2);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值