HDOJ--1007

Quoit Design

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 41711    Accepted Submission(s): 10843


Problem Description
Have you ever played quoit in a playground? Quoit is a game in which flat rings are pitched at some toys, with all the toys encircled awarded.
In the field of Cyberground, the position of each toy is fixed, and the ring is carefully designed so it can only encircle one toy at a time. On the other hand, to make the game look more attractive, the ring is designed to have the largest radius. Given a configuration of the field, you are supposed to find the radius of such a ring.

Assume that all the toys are points on a plane. A point is encircled by the ring if the distance between the point and the center of the ring is strictly less than the radius of the ring. If two toys are placed at the same point, the radius of the ring is considered to be 0.
 

Input
The input consists of several test cases. For each case, the first line contains an integer N (2 <= N <= 100,000), the total number of toys in the field. Then N lines follow, each contains a pair of (x, y) which are the coordinates of a toy. The input is terminated by N = 0.
 

Output
For each test case, print in one line the radius of the ring required by the Cyberground manager, accurate up to 2 decimal places. 
 

Sample Input
  
  
2 0 0 1 1 2 1 1 1 1 3 -1.5 0 0 0 0 1.5 0
 

Sample Output
  
  
0.71 0.00 0.75
 




通俗点讲就是让你求出空间中最近两点间的距离,一般有两种解法:暴力法或者分治法。开始我提交了3次,全部TLE,最后采用分治法才AC掉。

分治法就是将这些点分为几部分,分别求出各部分的最优解,在最后进行比较。

同样我觉得这里还有DP(动态规划)的思想在里面,不同意的就别喷我了。

以下是我的AC代码:

//杭电ACM1007--分治法+DP 
#include<iostream>
#include<cstdio>
#include<cmath>
#include<algorithm>
using namespace std;
struct point
{
    double x,y;
};
point arrp[100001];
point arrx[100001];
point arry[100001];
bool compx(point a,point b)
{
    if(a.x==b.x)
    return a.y<b.y;
    return a.x<b.x;
}
bool compy(point a,point b)
{
    if(a.y==b.y)
    return a.x<b.x;
    return a.y<b.y;
}
double getdistance(point a,point b)
{
    return sqrt(pow((a.x-b.x),2.0)+pow((a.y-b.y),2.0));
}
double mindistance(double a,double b)
{
    return a<=b ? a:b; 
}
double getmindistance(int l,int r)
{
    if(l==r) return 0;
    else if(l+1==r)return getdistance(arrp[l],arrp[r]);
    else if(l+2==r)
    {
        double tmp1=getdistance(arrp[l],arrp[l+1]);
        double tmp2=getdistance(arrp[l],arrp[r]);
        double tmp3=getdistance(arrp[l+1],arrp[r]);
        return mindistance(mindistance(tmp1,tmp2),tmp3);
    }
    int middle=(l+r)/2,j=0,k=0;
    double Mindistance=mindistance(getmindistance(l,middle),getmindistance(middle+1,r));
    for(int i=l;i<=r;i++)
    {
        if(fabs(arrp[i].x-arrp[middle].x)<Mindistance)
        {
            arrx[j++]=arrp[i];
        }
    }
    sort(arrx,arrx+j,compy);
    middle=(j+1)/2;
    for(int i2=0;i2<j;i2++)
    {
        if(fabs(arrx[i2].y-arrx[middle].y)<Mindistance)
        arry[k++]=arrx[i2];
    }
    for(int i3=0;i3<k;i3++)
    {
        for(int j=i3+1;j<k;j++)
        {
            double tmpdistance=getdistance(arry[i3],arry[j]);
            if(tmpdistance<Mindistance)
            Mindistance=tmpdistance;
        }
    }
    return Mindistance;
}
int main()
{
    
    int n;
    while(cin>>n && n!=0)
    {
        double Mindistance;
        for(int i4=0;i4<n;i4++)
        {
            cin>>arrp[i4].x>>arrp[i4].y;
        }
        sort(arrp,arrp+n,compx);
        Mindistance=getmindistance(0,n-1);
        cout.precision(2);
        cout<<fixed<<Mindistance/2<<endl;
    }
    return 0;
 } 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值