POJ 1273 Drainage Ditches (网络流最大流基础 Edmonds_Karp算法)

91 篇文章 1 订阅


Drainage Ditches
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 59219 Accepted: 22740

Description

Every time it rains on Farmer John's fields, a pond forms over Bessie's favorite clover patch. This means that the clover is covered by water for awhile and takes quite a long time to regrow. Thus, Farmer John has built a set of drainage ditches so that Bessie's clover patch is never covered in water. Instead, the water is drained to a nearby stream. Being an ace engineer, Farmer John has also installed regulators at the beginning of each ditch, so he can control at what rate water flows into that ditch.
Farmer John knows not only how many gallons of water each ditch can transport per minute but also the exact layout of the ditches, which feed out of the pond and into each other and stream in a potentially complex network.
Given all this information, determine the maximum rate at which water can be transported out of the pond and into the stream. For any given ditch, water flows in only one direction, but there might be a way that water can flow in a circle.

Input

The input includes several cases. For each case, the first line contains two space-separated integers, N (0 <= N <= 200) and M (2 <= M <= 200). N is the number of ditches that Farmer John has dug. M is the number of intersections points for those ditches. Intersection 1 is the pond. Intersection point M is the stream. Each of the following N lines contains three integers, Si, Ei, and Ci. Si and Ei (1 <= Si, Ei <= M) designate the intersections between which this ditch flows. Water will flow through this ditch from Si to Ei. Ci (0 <= Ci <= 10,000,000) is the maximum rate at which water will flow through the ditch.

Output

For each case, output a single integer, the maximum rate at which water may emptied from the pond.

Sample Input

5 4
1 2 40
1 4 20
2 4 20
2 3 30
3 4 10

Sample Output

50

Source

USACO 93

题目链接:http://poj.org/problem?id=1273

题目大意:有m个池塘(1为源点,m为汇点)n条水渠,给出这n条水渠所连接的池塘和所能流过的水量,求水渠中所能流过的水的最大容量

题目分析:基础的网络流最大流问题,采用Edmonds_Karp算法,详细见程序注释

#include <cstdio>
#include <cstring>
#include <queue>
using namespace std;
int const MAX = 205;
int m, n;
int c[MAX][MAX];    //边容量
int f[MAX][MAX];    //边实际流量
int pre[MAX];       //记录增广路的路径
int a[MAX];         //残余网络

int Edmonds_Karp(int s, int t)
{
    int ans = 0;
    queue <int> q;
    while(true)
    {
        memset(a, 0, sizeof(a));
        a[s] = 2147483647; //源点标号设为无限大
        q.push(s);          
        while(!q.empty())   //利用BFS找增广路
        {
            int u = q.front();
            q.pop();
            for(int v = 1; v <= n; v++)
            {
                //某点未被增广且该点的容量大于流量
                if(!a[v] && c[u][v] > f[u][v])
                {
                    q.push(v);
                    //求得s-v路径上的最大改进量,即最小残量
                    a[v] = a[u] < c[u][v] - f[u][v] ? a[u] : c[u][v] - f[u][v];
                    pre[v] = u;
                }
            }
        }
        //若找不到增广路则退出
        if(a[t] == 0)
            break;
        //从汇点沿着记录的增广路路径往源点走
        for(int u = t; u != s; u = pre[u])
        {
            f[pre[u]][u] += a[t];   //更新正向流量    
            f[u][pre[u]] -= a[t];   //更新反向流量
        }
        ans += a[t];    //加上改进量
    }
    return ans;
}

int main()
{
    int u, v, w;
    while(scanf("%d %d", &m, &n) != EOF)
    {
        memset(c, 0, sizeof(c));
        memset(f, 0, sizeof(f));
        //初始化容量网络,开始为零流
        for(int i = 0; i < m; i++)
        {
            scanf("%d %d %d", &u, &v, &w);
            c[u][v] += w;   //可能有重边,需叠加
        }
        printf("%d\n", Edmonds_Karp(1, n));
    }
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值