uva 10271 Chopsticks

原题:
In China, people use a pair of chopsticks to get food on the table, but Mr. L is a bit different. He uses
a set of three chopsticks – one pair, plus an EXTRA long chopstick to get some big food by piercing
it through the food. As you may guess, the length of the two shorter chopsticks should be as close as
possible, but the length of the extra one is not important, as long as it’s the longest. To make things
clearer, for the set of chopsticks with lengths A, B, C (A ≤ B ≤ C), (A − B)
2
is called the “badness”
of the set.
It’s December 2nd, Mr.L’s birthday! He invited K people to join his birthday party, and would like
to introduce his way of using chopsticks. So, he should prepare K + 8 sets of chopsticks(for himself,
his wife, his little son, little daughter, his mother, father, mother-in-law, father-in-law, and K other
guests). But Mr.L suddenly discovered that his chopsticks are of quite different lengths! He should find
a way of composing the K + 8 sets, so that the total badness of all the sets is minimized.
Input
The first line in the input contains a single integer T, indicating the number of test cases (1 ≤ T ≤ 20).
Each test case begins with two integers K, N (0 ≤ K ≤ 1000, 3K + 24 ≤ N ≤ 5000), the number of
guests and the number of chopsticks.
There are N positive integers Li on the next line in non–decreasing order indicating the lengths of
the chopsticks (1 ≤ Li ≤ 32000).
Output
For each test case in the input, print a line containing the minimal total badness of all the sets.
Note: For the sample input, a possible collection of the 9 sets is:
8,10,16; 19,22,27; 61,63,75; 71,72,88; 81,81,84; 96,98,103; 128,129,148; 134,134,139; 157,157,160
Sample Input
1
1 40
1 8 10 16 19 22 27 33 36 40 47 52 56 61 63 71 72 75 81 81 84 88 96 98
103 110 113 118 124 128 129 134 134 139 148 157 157 160 162 164
Sample Output
23
大意:
给你8+n根棍子,让你分成k组,每组三个,其中有个值叫badness。这个值等于每组当中最短的两根棍的平方差。现在问你把这8+n根棍分成k组,badness最小是多少。
注意数据给你是非降序序列。

#include<iostream>
#include<algorithm>
#include<map>
#include<string>
#include<cstring>
#include<sstream>
#include<cstdio>
#include<vector>
#include<cmath>
#include<stack>
#include<queue>
#include<iomanip>
#include<set>
#include<fstream>
#include <climits>
using namespace std;

int dp[5001][1001];
int cho[5001];
int main()
{
    ios::sync_with_stdio(false);
    int t,k,n;
    cin>>t;
    while(t--)
    {
        cin>>k>>n;
        k+=8;
        for(int i=n;i>=1;i--)
            cin>>cho[i];
        memset(dp,0,sizeof(dp));
        for(int i=1;i<=n;i++)
            for(int j=1;j<=k;j++)
            dp[i][j]=INT_MAX;
        for(int i=3;i<=n;i++)
        {
            for(int j=1;j<=k;j++)
                if(i>=j*3)
                dp[i][j]=min(dp[i-1][j],dp[i-2][j-1]+(cho[i]-cho[i-1])*(cho[i]-cho[i-1]));
        }
        cout<<dp[n][k]<<endl;
    }
//  input.close();
//  output.close();
    return 0;
}




解答:
刚看的时候还有点蒙,如果数据小点还能手动模拟模拟用来检验一下自己的转移方程是否正确。但是这数据比较大,手动模拟很费事。首先考虑状态,因为是n根棍子选k个,所以很容易确定状态是二维的,设置为dp[i][j]表示前i个棍子选出j组时的最小badness。接下来看状态转移过程,首先有一个关键点要想到,其实也挺好想,因为题目中已经给出提示了,就是给你的数据是按照非降序排列。比如现在又三个数A,B,C,D其中A<=B<=C<=D,现在要随便给你一个A,B,C,D当中的一个数X,让你另外找一个数Y使得(X-Y)^2最小,很明显是找和X相邻的两个数进行判断。状态转移的过程类似,第i个棍子选用或者是不选用。如果不选用选用表示为dp[i-1][j],意思是不用第i根棍组成j组。如果用第i根棍,那么dp[i-2][j-1]+(cho[i-1]-cho[i])^2,表示前i-2个棍子组成j-1组加上第i,i-1,i-2根棍组成的组的badness。(这里记得要把棍子的长度顺序倒过来)
则dp[i][j]=min(dp[i-1][j],dp[i-2][j-1]+(cho[i]-cho[i-1])*(cho[i]-cho[i-1]));

注意边界处理即可~

1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看REAdMe.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。 1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看REAdMe.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。 1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看READme.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值