hdu 1013 Digital Roots(模拟 || 数论)

题目:http://acm.hdu.edu.cn/showproblem.php?pid=1013

Digital Roots

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 59645    Accepted Submission(s): 18661


Problem Description
The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.

For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.
 

Input
The input file will contain a list of positive integers, one per line. The end of the input will be indicated by an integer value of zero.
 

Output
For each integer in the input, output its digital root on a separate line of the output.
 

Sample Input
  
  
24 39 0
 

Sample Output
  
  
6 3
分析:大意就是12435-->15-->6,每位数字相加得到新数,知道新数是一位数。
可以模拟,就是不断相加,相邻数字最大和不过是9+9=18,所以可以从左到右不断消灭,直到最后一位,比如:2381-->0581-->0131-->0041-->0005。结果就是5。
也可以发现循环节,利用这个特点得到答案。
模拟:
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
const int maxn=1e4+10;
char str[maxn];
int main()
{
    while(~scanf("%s",str)&&str[0]!='0'){
         int i,length=strlen(str),q1,q2;
         for(i=1;i<length;i++){
             int res=str[i-1]-'0'+str[i]-'0';
             if(res>=10){
                  q1=res/10;
                  q2=res%10;
                  res=q1+q2;
             }
             str[i-1]=0;
             str[i]=res+'0';
         }
         printf("%c\n",str[length-1]);
    }
    return 0;
}
数论:
/*
number: 1 2 3 4 5 6 7 8 9 10 11 12 13……18 19 20 21 22 23 24……100 101 102 103 104……108 109 110……
root:   1 2 3 4 5 6 7 8 9  1  2  3  4…… 9  1  2  3  4  5  6……  1   2   3   4   5……  9  1  2……
循环节就是9!
*/
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
char str[1010];
int main()
{
    while(~scanf("%s",str)&&str[0]!='0'){
        int sum=0;
        int i,length=strlen(str);
        for(i=0;i<length;i++){
            sum+=str[i]-'0';
        }
        printf("%d\n",(sum-1)%9+1);
    }
    return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值