HDU 1013 Digital Roots 大数 水题

Digital Roots

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 73352    Accepted Submission(s): 22899


Problem Description
The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.

For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.
 

Input
The input file will contain a list of positive integers, one per line. The end of the input will be indicated by an integer value of zero.
 

Output
For each integer in the input, output its digital root on a separate line of the output.
 

Sample Input
  
  
24 39 0
 

Sample Output
  
  
6 3
 

Source
 

Recommend
We have carefully selected several similar problems for you:   1017  1021  1004  1018  1048 
 
一开始以为是水题,虽然没给具体几位数,试着去水了一下,直接WA了,诶,然后就换了大数,那个sum的地方也是试着去试一下,没想到是正确的理论,嗯,一会去研究下到底怎么回事,这个题大数就可以过,其他的都有问题
ac代码:
#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;
int main()
{
	char s[1005];
	int i,sum;
	
	while(gets(s))
	{
		//puts(s);
		if(s[0]=='0')
			break;
		sum=0;
		for(i=0;s[i]!='\0';i++)
		{
			sum+=(s[i]-'0');
			if(sum>9)//这里设计到数论中的一个知识,叫啥啥啥不变,嗯,记住就好,嘿嘿 
			{
				int n=sum;
				sum=0;
				while(n)
				{
					sum+=n%10;
					n=n/10;
				}
			}
		}
		printf("%d\n",sum);
		
	}
	
	return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值