UVA1584 UVALive3225 Circular Sequence【水题】

  Some DNA sequences exist in circular forms as in the following figure, which shows a circular sequence “CGAGTCAGCT”, that is, the last symbol “T” in “CGAGTCAGCT” is connected to the first symbol “C”. We alwaysread a circular sequence in the clockwise direction.

  Since it is not easy to store a circular sequence in a computer as it is, we decided to store it as a linear sequence. However, there can be many linear sequences that are obtained from a circular sequence by cutting any place of the circular sequence. Hence, we also decided to store the linear sequence that is lexicographically smallest among all linear sequences that can be obtained from a circular sequence.


  Your task is to find the lexicographically smallest sequence from a given circular sequence. For the example in the figure, the lexicographically smallest sequence is “AGCTCGAGTC”. If there are two or more linear sequences that are lexicographically smallest, you are to find any one of them (in fact, they are the same).

Input

The input consists of T test cases. The number of test cases T is given on the first line of the input file. Each test case takes one line containing a circular sequence that is written as an arbitrary linear sequence. Since the circular sequences are DNA sequences, only four symbols, ‘A’, ‘C’, ‘G’ and ‘T’, are allowed. Each sequence has length at least 2 and at most 100.

Output

Print exactly one line for each test case. The line is to contain the lexicographically smallest sequence for the test case.

Sample Input

2

CGAGTCAGCT

CTCC

Sample Output

AGCTCGAGTC

CCCT


Regionals 2004 >> Asia - Seoul


问题链接UVA1584 UVALive3225 Circular Sequence

问题简述:(略)

问题分析

  这个问题是寻找循环串中的最小者。

  不移动字符串是关键,不然就会浪费时间。

程序说明

  程序中,封装了两个功能函数cirstrcmp()和cirstrprintf(),使得主程序的逻辑大为简化。这两个函数是通用性的函数,完全封装,与全局变量没有关系。


AC通过的C语言程序如下:

/* UVA1584 UVALive3225 Circular Sequence */

#include <stdio.h>
#include <string.h>

#define MAXN 100

/* 循环串比较,a[s]和a[t]开始的两个串进行比较,s>t,s=t,s<t返回值分别为负,0,正 */
int cirstrcmp(char a[], int s, int t, int length)
{
    int count, i, j;

    count = length;
    for(i = s, j = t; count-- > 0; i = ++s % length, j = ++t % length) {
        if(a[i] == a[j])
            continue;
        return a[i] - a[j];
    }

    return 0;
}

void cirstrprintf(char a[], int start, int length)
{
    int count=0, i;

    for(i = start; count++ < length; i = (i + 1) % length)
        putchar(a[i]);
    putchar('\n');
}

int main(void)
{
    int t, min, len, i;
    char s[MAXN+1];

    scanf("%d", &t);
    while(t--) {
        scanf("%s", s);

        len = strlen(s);

        min = 0;
        for(i=1; i<len; i++)
            if(cirstrcmp(s, i, min, len) < 0)
                min = i;

        cirstrprintf(s, min, len);
    }

    return 0;
}


  • 3
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值