UVA439 POJ2243 HDU1372 ZOJ1091 Knight Moves【BFS】

708 篇文章 19 订阅
509 篇文章 9 订阅

 

Knight Moves

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 14681 Accepted: 8228

 

Description

A friend of you is doing research on the Traveling Knight Problem (TKP) where you are to find the shortest closed tour of knight moves that visits each square of a given set of n squares on a chessboard exactly once. He thinks that the most difficult part of the problem is determining the smallest number of knight moves between two given squares and that, once you have accomplished this, finding the tour would be easy.
Of course you know that it is vice versa. So you offer him to write a program that solves the "difficult" part.

Your job is to write a program that takes two squares a and b as input and then determines the number of knight moves on a shortest route from a to b.

Input

The input will contain one or more test cases. Each test case consists of one line containing two squares separated by one space. A square is a string consisting of a letter (a-h) representing the column and a digit (1-8) representing the row on the chessboard.

Output

For each test case, print one line saying "To get from xx to yy takes n knight moves.".

Sample Input

e2 e4
a1 b2
b2 c3
a1 h8
a1 h7
h8 a1
b1 c3
f6 f6

Sample Output

To get from e2 to e4 takes 2 knight moves.
To get from a1 to b2 takes 4 knight moves.
To get from b2 to c3 takes 2 knight moves.
To get from a1 to h8 takes 6 knight moves.
To get from a1 to h7 takes 5 knight moves.
To get from h8 to a1 takes 6 knight moves.
To get from b1 to c3 takes 1 knight moves.
To get from f6 to f6 takes 0 knight moves.

Source

Ulm Local 1996

 

 

 

问题链接UVA439 POJ2243 HDU1372 ZOJ1091 Knight Moves

题意简述

  给出国际象棋棋盘中的两个点,求马从一个点跳到另一个点的最少步数。

问题分析

  典型的BFS问题。在BFS搜索过程中,马跳过的点就不必再跳了,因为这次再跳下去不可能比上次步数少。

程序说明

  程序中,使用了一个队列来存放中间节点,但是每次用完需要清空。

  这里给出两个版本的程序,有一个是设置了边界的。

 

AC的C++语言程序如下:

 

/* UVA439 POJ2243 HDU1372 ZOJ1091 Knight Moves */

#include <iostream>
#include <cstring>
#include <queue>

using namespace std;

const int DIRECTSIZE = 8;
struct direct {
    int drow;
    int dcol;
} direct[DIRECTSIZE] =
    {{-2, 1}, {-1, 2}, {1, 2}, {2, 1}, {2, -1}, {1, -2}, {-1, -2}, {-2, -1}};

const int MAXN = 8;
char grid[MAXN][MAXN];

struct node {
    int row;
    int col;
    int level;
};

node start, end2;
int ans;

void bfs()
{
    queue<node> q;

    memset(grid, ' ', sizeof(grid));

    grid[start.row][start.col] = '*';

    ans = 0;
    q.push(start);

    while(!q.empty()) {
        node front = q.front();
        q.pop();

        if(front.row == end2.row && front.col == end2.col) {
            ans = front.level;
            break;
        }

        for(int i=0; i<DIRECTSIZE; i++) {
            int nextrow = front.row + direct[i].drow;
            int nextcol = front.col + direct[i].dcol;

            if(0 <= nextrow && nextrow < MAXN && 0 <= nextcol && nextcol < MAXN)
                if(grid[nextrow][nextcol] == ' ') {
                    grid[nextrow][nextcol] = '*';
                    node v;
                    v.row = nextrow;
                    v.col = nextcol;
                    v.level = front.level + 1;
                    q.push(v);
                }
        }
    }
}

int main(void)
{
    char startc, endc;

    while(cin >> startc >> start.row >> endc >> end2.row) {
        start.row--;
        start.col = startc - 'a';
        start.level = 0;
        end2.row--;
        end2.col = endc - 'a';

        bfs();

        printf("To get from %c%d to %c%d takes %d knight moves.\n", startc, start.row+1, endc, end2.row+1, ans);
    }

    return 0;
}


另外一版AC的C++语言程序如下:

 

 

/* UVA439 POJ2243 HDU1372 ZOJ1091 Knight Moves */

#include <cstdio>
#include <cstring>
#include <queue>

using namespace std;

#define MAXN 8

#define DIRECTSIZE 8

struct direct {
    int drow;
    int dcol;
} direct[DIRECTSIZE] =
    {{-2, 1}, {-1, 2}, {1, 2}, {2, 1}, {2, -1}, {1, -2}, {-1, -2}, {-2, -1}};

char grid[MAXN+4][MAXN+4];

int startcol, startrow, endcol, endrow;
int ans;

struct node {
    int row;
    int col;
    int level;
};

queue<node> q;

void bfs()
{
    ans = 0;
    node start;
    start.row = startrow;
    start.col = startcol;
    start.level = 0;
    q.push(start);

    while(!q.empty()) {
        node front = q.front();
        q.pop();

        if(front.row == endrow && front.col == endcol) {
            ans = front.level;
            break;
        }

        for(int i=0; i<DIRECTSIZE; i++) {
            int nextrow = front.row + direct[i].drow;
            int nextcol = front.col + direct[i].dcol;
            if(grid[nextrow][nextcol] == ' ') {
                node v;
                v.row = nextrow;
                v.col = nextcol;
                v.level = front.level + 1;
                q.push(v);
            }
        }

        grid[front.row][front.col] = '*';
    }
}

int main(void)
{
    int i;
    char startc, endc;

    while(scanf("%c%d %c%d", &startc, &startrow, &endc, &endrow) != EOF) {
        getchar();

        while(!q.empty())
            q.pop();

        startcol = startc - 'a' + 2;
        startrow += 1;
        endcol = endc - 'a' + 2;
        endrow += 1;

        memset(grid, ' ', sizeof(grid));
        for(i=0; i<MAXN+4; i++) {
            grid[0][i] = '*';
            grid[1][i] = '*';
            grid[MAXN+2][i] = '*';
            grid[MAXN+3][i] = '*';

            grid[i][0] = '*';
            grid[i][1] = '*';
            grid[i][MAXN+2] = '*';
            grid[i][MAXN+3] = '*';
        }

        bfs();

        printf("To get from %c%d to %c%d takes %d knight moves.\n", startc, startrow-1, endc, endrow-1, ans);
    }

    return 0;
}

 

 

 

 

 

 

  • 2
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 2
    评论
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值