HDU1014 POJ1597 UVALive5492 UVA408 ZOJ1314 Uniform Generator【随机函数+水题】

708 篇文章 20 订阅
509 篇文章 9 订阅

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 5584 Accepted: 2607

Description

Computer simulations often require random numbers. One way to generate pseudo-random numbers is via a function of the form  
     seed(x+1) = [ seed(x) + STEP ] % MOD



     where "%" is the modulus operator.

Such a function will generate pseudo-random numbers (seed) between 0 and MOD-1. One problem with functions of this form is that they will always generate the same pattern over and over. In order to minimize this effect, selecting the STEP and MOD values carefully can result in a uniform distribution of all values between (and including) 0 and MOD-1.  

For example, if STEP=3 and MOD=5, the function will generate the series of pseudo-random numbers 0, 3, 1, 4, 2 in a repeating cycle. In this example, all of the numbers between and including 0 and MOD-1 will be generated every MOD iterations of the function. Note that by the nature of the function to generate the same seed(x+1) every time seed(x) occurs means that if a function will generate all the numbers between 0 and MOD-1, it will generate pseudo-random numbers uniformly with every MOD iterations.  

If STEP = 15 and MOD = 20, the function generates the series 0, 15, 10, 5 (or any other repeating series if the initial seed is other than 0). This is a poor selection of STEP and MOD because no initial seed will generate all of the numbers from 0 and MOD-1.  

Your program will determine if choices of STEP and MOD will generate a uniform distribution of pseudo-random numbers.  

Input

Each line of input will contain a pair of integers for STEP and MOD in that order (1<=STEP,MOD<=100000).

Output

For each line of input, your program should print the STEP value right-justified in columns 1 through 10, the MOD value right-justified in columns 11 through 20 and either "Good Choice" or "Bad Choice" left-justified starting in column 25. The "Good Choice" message should be printed when the selection of STEP and MOD will generate all the numbers between and including 0 and MOD-1 when MOD numbers are generated. Otherwise, your program should print the message "Bad Choice". After each output test set, your program should print exactly one blank line.

Sample Input

3 5
15 20
63923 99999

Sample Output

         3         5    Good Choice

        15        20    Bad Choice

     63923     99999    Good Choice

Source


Regionals 1996 >> North America - South Central USA


问题链接HDU1014 POJ1597 UVALive5492 UVA408 ZOJ1314 Uniform Generator

问题简述:(略)

问题分析:这是一个数论题,可以根据题意用暴力法来求解,也可以根据数论原理使用最大公约数来求解。

程序说明:(略)

题记:(略)

 

AC的C语言程序如下

/* HDU1014 POJ1597 UVALive5492 UVA408 ZOJ1314 Uniform Generator */

#include <stdio.h>

int gcd(int a, int b)
{
    return b == 0 ? a : gcd(b, a % b);
}

int main(void)
{
    int step, mod;

    while (scanf("%d%d", &step, &mod) != EOF)
        printf("%10d%10d    %s\n\n", step, mod, gcd(step, mod) == 1 ? "Good Choice" : "Bad Choice");

    return 0;
}

AC的C语言程序如下

/* HDU1014 POJ1597 UVALive5492 UVA408 ZOJ1314 Uniform Generator */

#include <stdio.h>
#include <string.h>

#define N 100000
int a[N + 1];

int main(void)

{
    int step, mod, i;

    while (scanf("%d%d", &step, &mod) != EOF) {
        memset(a, 0, sizeof(a));

        i = 0;
        while(! a[i]) {
            a[i] = 1;
            i = (i + step) % mod;
        }

        for(i=0; i<mod; i++)
            if(a[i] == 0)
                break;

        printf("%10d%10d    %s\n\n", step, mod, i == mod ? "Good Choice" : "Bad Choice");
    }

    return 0;
}


评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值