POJ1256 UVA195 UVALive5605 Anagram【全排列】

509 篇文章 9 订阅
281 篇文章 4 订阅

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 21728 Accepted: 8618

Description

You are to write a program that has to generate all possible words from a given set of letters.  
Example: Given the word "abc", your program should - by exploring all different combination of the three letters - output the words "abc", "acb", "bac", "bca", "cab" and "cba".  
In the word taken from the input file, some letters may appear more than once. For a given word, your program should not produce the same word more than once, and the words should be output in alphabetically ascending order.  

Input

The input consists of several words. The first line contains a number giving the number of words to follow. Each following line contains one word. A word consists of uppercase or lowercase letters from A to Z. Uppercase and lowercase letters are to be considered different. The length of each word is less than 13.

Output

For each word in the input, the output should contain all different words that can be generated with the letters of the given word. The words generated from the same input word should be output in alphabetically ascending order. An upper case letter goes before the corresponding lower case letter.

Sample Input

3
aAb
abc
acba

Sample Output

Aab
Aba
aAb
abA
bAa
baA
abc
acb
bac
bca
cab
cba
aabc
aacb
abac
abca
acab
acba
baac
baca
bcaa
caab
caba
cbaa

Hint

An upper case letter goes before the corresponding lower case letter.  
So the right order of letters is 'A'<'a'<'B'<'b'<...<'Z'<'z'.

Source


Regionals 1995 >> Europe - Southwestern


问题链接POJ1256 UVA195 UVALive5605 Anagram

问题简述:(略)

问题分析:(略)

程序说明

  全排列问题用算法库中的置换函数next_permutation()实现是十分简单的。

  还需要用到算法库中的排序函数sort()实现字符串排序。进行比较时,需要按照暗示进行排序,将字符映射到整数再进行比较就简单了。

题记:(略)

参考链接:(略)


AC的C++语言程序如下:

/* POJ1256 UVA195 UVALive5605 Anagram */

#include <iostream>
#include <algorithm>
#include <ctype.h>

using namespace std;

// 按照'A'<'a'<'B'<'b'<...<'Z'<'z'的顺序排序
inline int val(char c)
{
    return isupper(c) ? (c - 'A') * 2 : (c - 'a') * 2 + 1;
}

bool cmp(const char& a, const char& b)
{
    return val(a) < val(b);
}

int main()
{
    int n;
    string s;

    cin >> n;
    while(n--) {
        cin >> s;

        sort(s.begin(), s.end(), cmp);

        do {
            cout << s << endl;
        } while(next_permutation(s.begin(), s.end(), cmp));
    }

    return 0;
}





评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值