POJ2663 HDU1143 UVA10918 Tri Tiling【递推】

708 篇文章 19 订阅
509 篇文章 9 订阅

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 11172 Accepted: 5623

Description

In how many ways can you tile a 3xn rectangle with 2x1 dominoes?  
Here is a sample tiling of a 3x12 rectangle.  

Input

Input consists of several test cases followed by a line containing -1. Each test case is a line containing an integer 0 <= n <= 30.

Output

For each test case, output one integer number giving the number of possible tilings.

Sample Input

2
8
12
-1

Sample Output

3
153
2131

Source


问题链接POJ2663 HDU1143 UVA10918 Tri Tiling

问题简述:(略)

问题分析:这是一个递推组合的问题,关键是找出递推函数来。不解释!

程序说明:打表是必要的!

题记:(略)

参考链接:(略)


AC的C++语言程序如下:

/* POJ2663 HDU1143 UVA10918 Tri Tiling */

#include <iostream>
#include <stdio.h>

using namespace std;

typedef unsigned long long ULL;

const int N = 30;
ULL tiling[N + 1];

void maketable()
{
    ULL all;

    tiling[0] = 1;
    tiling[1] = 3;

    all = 0;
    for(int i=2; i<=N; i++) {
        tiling[i] = 3 * tiling[i - 1] + 2 * (all + 1);
        all += tiling[i - 1];
    }
}

int main()
{
    maketable();

    int n;
    while(~scanf("%d", &n) && n != -1) {
        if(n % 2)
            printf("0\n");
        else
            printf("%lld\n", tiling[n / 2]);
    }

    return 0;
}





评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值