UVA264 UVALive5373 UVALive3034 Count on Cantor【数学】

281 篇文章 4 订阅
132 篇文章 1 订阅

One of the famous proofs of modern mathematics is Georg Cantor’s demonstration that the set of rational numbers is enumerable. The proof works by using an explicit enumeration of rational numbers as shown in the diagram below.

    1/1 1/2 1/3 1/4 1/5 . . .

    2/1 2/2 2/3 2/4

    3/1 3/2 3/3

    4/1 4/2

    5/1

  In the above diagram, the first term is 1/1, the second term is 1/2, the third term is 2/1, the fourth term is 3/1, the fifth term is 2/2, and so on.

Input and Output

You are to write a program that will read a list of numbers in the range from 1 to 107 and will print for each number the corresponding term in Cantor’s enumeration as given below. No blank line should appear after the last number.

  The input list contains a single number per line and will be terminated by end-of-file.

Sample input

3

14

7

Sample output

TERM 3 IS 2/1

TERM 14 IS 2/4

TERM 7 IS 1/4

Regionals 1993 >> North America - East Central NA

Regionals 2004 >> Europe - Southeastern


问题链接UVA264 UVALive5373 UVALive3034 Count on Cantor

问题简述:(略)

问题分析

  这个题的关键是找到规律,其他不解释。

程序说明:(略)

题记:(略)


参考链接:(略)


AC的C++语言程序如下:

/* UVA264 UVALive5373 UVALive3034 Count on Cantor */

#include <bits/stdc++.h>

using namespace std;

int main()
{
    int n, sum, i;

    while(~scanf("%d", &n)) {
        sum = 0;

        for(i=0; n>sum; i++)
            sum += i;

        if(i % 2)
            printf("TERM %d IS %d/%d\n", n, i - (sum - n + 1), sum - n + 1);
        else
            printf("TERM %d IS %d/%d\n", n, sum - n + 1, i - (sum - n + 1));
    }

    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值