UVa 264 Count on Cantor

Count on Cantor

One of the famous proofs of modern mathematics is Georg Cantor's demonstration that the set of rational numbers is enumerable. The proof works by using an explicit enumeration of rational numbers as shown in the diagram below.

displaymath27

In the above diagram, the first term is 1/1, the second term is 1/2, the third term is 2/1, the fourth term is 3/1, the fifth term is 2/2, and so on.

Input and Output

You are to write a program that will read a list of numbers in the range from 1 to tex2html_wrap_inline29 and will print for each number the corresponding term in Cantor's enumeration as given below. No blank line should appear after the last number.

The input list contains a single number per line and will be terminated by end-of-file.

Sample input

3
14
7

Sample output

TERM 3 IS 2/1
TERM 14 IS 2/4
TERM 7 IS 1/4


这个简单的题我几乎把所有的数都试过了,而且中间也改了不少错了,可是还是WA,无奈去网上学习他人经验,发现一个比较高效的解法,


AC代码:

#include <stdio.h>
#include <math.h>

int main(int argc, const char * argv[]) {
    int input;
    int m;
    
    while (scanf("%d", &input) == 1) {
        printf("TERM %d IS ", input);
        m = (1 + sqrt(8 * input - 7)) / 2;
        input -= m * (m + 1) / 2;
        if (m % 2) {
            printf("%d/%d\n",1 - input, input + m);
        } else {
            printf("%d/%d\n", input + m, 1 - input);
        }
    }
    
    return 0;
    
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值