poj 1847(floyd) Tram

Tram
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 8548 Accepted: 3093

Description

Tram network in Zagreb consists of a number of intersections and rails connecting some of them. In every intersection there is a switch pointing to the one of the rails going out of the intersection. When the tram enters the intersection it can leave only in the direction the switch is pointing. If the driver wants to go some other way, he/she has to manually change the switch.

When a driver has do drive from intersection A to the intersection B he/she tries to choose the route that will minimize the number of times he/she will have to change the switches manually.

Write a program that will calculate the minimal number of switch changes necessary to travel from intersection A to intersection B.

Input

The first line of the input contains integers N, A and B, separated by a single blank character, 2 <= N <= 100, 1 <= A, B <= N, N is the number of intersections in the network, and intersections are numbered from 1 to N.

Each of the following N lines contain a sequence of integers separated by a single blank character. First number in the i-th line, Ki (0 <= Ki <= N-1), represents the number of rails going out of the i-th intersection. Next Ki numbers represents the intersections directly connected to the i-th intersection.Switch in the i-th intersection is initially pointing in the direction of the first intersection listed.

Output

The first and only line of the output should contain the target minimal number. If there is no route from A to B the line should contain the integer "-1".

Sample Input

3 2 1
2 2 3
2 3 1
2 1 2

Sample Output

0
题目大意:
有N个点 接下来的N行分别为点i的情况:第一个数字k表示与该点连通的点的个数,接下来输入k个数,
表示与点i相连的点的编号,第一个所连的点为不用手动改而直接通过,其余的点通过的话要改一次,求从A点到B点改扳手的最小次数。

思路:转化为最短路处理,在边权的处理上,不改动扳手的边权值为0,改动扳手的边权值为1;
本题第一种方法:由于数据量不是很大,图也不是很疏松,采用邻接矩阵足以,其次,虽然floyd的算法是n^3,但是处理稠密图还是相当快速,干净的。
第二种方案,也可以用用单原最短路处理,我用的是spfa:

方法一:
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn=200;
const int inf=10000000;
int G[maxn][maxn];

int main()
{
    int i,j,n,m,k,st,ed;
    while(scanf("%d%d%d",&n,&st,&ed)!=EOF)
    {
    	memset(G,0,sizeof(G));
    	for(i=1;i<=n;i++)
            for(j=1;j<=n;j++)
                G[i][j]=inf;
    	for(i=1;i<=n;i++)
    	{
    		scanf("%d",&m);
    		for(j=1;j<=m;j++)
    		{
    			int t;
    			scanf("%d",&t);
    			if(j==1)
    				G[i][t]=0;
    			else
    				G[i][t]=1;
    		}
    	}
    	for(k=1;k<=n;k++)
    	{
    		for(i=1;i<=n;i++)
    		{
    			for(j=1;j<=n;j++)
    				G[i][j]=min(G[i][j],G[i][k]+G[k][j]);
    		}
    	}
    	if(G[st][ed]==inf)
    		printf("-1\n");
    	else
    		printf("%d\n",G[st][ed] );
    }
    return 0;
}


方法二:spfa

#include <iostream>
#include <cstring>
#include <cstdio>
#include <cmath>
#include <algorithm>
using namespace std;
const int maxn=105;
const int maxe=100*100; //边数一定要先与估计好
const int inf=0x1fffff;
struct NodeEdge{
    int to;
    int w;
    int next;
}edges[maxn*2];
int head[maxn],dist[maxn];
int numEdges,n,st,ed;
void addEdge(int u,int v,int w)
{
    numEdges++;
    edges[numEdges].to=v;
    edges[numEdges].w=w;
    edges[numEdges].next=head[u];
    head[u]=numEdges;
}
bool spfa(int s)
{
    int vis[maxn],output[maxn];
    int que[maxe],fro=0,tail=0; //队列空间开小了...一开始que[]只开到了105,一直wa。。小心呀,
    memset(vis,0,sizeof(vis));  //早知道就用stl了...T_T
    memset(output,0,sizeof(output));
    for(int i=1;i<=n;i++)   dist[i]=inf;
    dist[st]=0;
    que[fro]=st;
    vis[st]=1;
    while(fro<=tail){
        int top=que[fro++];
        vis[top]=0;
        output[top]++;
        if(output[top]>n)   return false;
        for(int k=head[top];k!=-1;k=edges[k].next){
            if(dist[edges[k].to]>dist[top]+edges[k].w){ //松弛操作
                dist[edges[k].to]=dist[top]+edges[k].w;
                if(!vis[edges[k].to]){   //若该节点没有被访问,则入队
                    vis[edges[k].to]=1;
                    que[++tail]=edges[k].to;
                }
            }
        }
    }
    return true;
}
int main()
{
    //freopen("in.txt","r",stdin);
    while(scanf("%d%d%d",&n,&st,&ed)==3){
       memset(head,-1,sizeof(head));
       memset(edges,0,sizeof(edges));
       numEdges=0;
       int t,v;
       for(int i=1;i<=n;i++){
            scanf("%d",&t);
            for(int j=1;j<=t;j++){
                scanf("%d",&v);
                if(j==1)    addEdge(i,v,0); //初始防线边权为0
                else    addEdge(i,v,1);  //其他的边权都为1
            }
       }
       spfa(st);
       if(dist[ed]==inf){
            printf("-1\n");
       }else{
            printf("%d\n",dist[ed]);
       }
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值