PAT 1024. Palindromic Number (25)【精华】

1024. Palindromic Number (25)

时间限制
400 ms
内存限制
32000 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Non-palindromic numbers can be paired with palindromic ones via a series of operations. First, the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number, this is repeated until it gives a palindromic number. For example, if we start from 67, we can obtain a palindromic number in 2 steps: 67 + 76 = 143, and 143 + 341 = 484.

Given any positive integer N, you are supposed to find its paired palindromic number and the number of steps taken to find it.

Input Specification:

Each input file contains one test case. Each case consists of two positive numbers N and K, where N (<= 1010) is the initial numer and K (<= 100) is the maximum number of steps. The numbers are separated by a space.

Output Specification:

For each test case, output two numbers, one in each line. The first number is the paired palindromic number of N, and the second number is the number of steps taken to find the palindromic number. If the palindromic number is not found after K steps, just output the number obtained at the Kth step and K instead.

Sample Input 1:
67 3
Sample Output 1:
484
2
Sample Input 2:
69 3
Sample Output 2:
1353
3

提交代码

/*使用变量之前首先要想到初始化。。。
  返回指针类型必须是全局数组!!因为局部变量是共用的,不断被销毁。。。。
  int 修改成long型整数,long型也不足以表示,从13分->18分。。。
  最终改为字符型。。。重新定义加法,终于AC。。。。 
  AC不容易啊~~~~~~ 
*/
#include<stdio.h>
#include<string.h>
int cnt;
const int MAX=100;
char  ans[MAX],tmp[MAX];//用于传参函数的返回值
bool isPalin;

bool isPa(char x[])  //判断一个数是否对称~~~ 比如12321是对称的
{
	isPalin=1;
	int len=strlen(x),i;
	for(i=0;i<=(len-1)/2;i++){
		if(x[i]!=x[len-1-i]){
			isPalin=0;
			break;
		}
	}
	return isPalin;
}
char* rever(char x[])  //把一个字符数翻转过来~~~ 比如12354->45321
{
	int i,len=strlen(x);
	for(i=0;i<MAX;i++)//每次初始化tmp[]为空。。不然strlen(tmp)每次都是最大的字符数. 
		tmp[i]=0;     //执行完后strlen(tmp)为0
	for(i=0;i<len;i++)
		tmp[i]=x[len-1-i];
	return tmp;
}
char* addstr(char x[],char y[])  //把两个字符型的数相加。。返回指针类型必须是全局数组!!因为局部变量是共用的,不断被销毁。。。。
{
	int carry=0,i,j=0,sum;
	char tmp1[100];  //用于反常规的保存数字,由于反常使用,故可进位扩展。。。
	int len1=strlen(x);
	for(i=0;i<MAX;i++){//每次初始化ans[]为空。。不然strlen(ans)每次都是最大的字符数. 
		ans[i]=0; tmp1[i]=0;
	}
	for(i=len1-1;i>=0;i--){
		sum=x[i]-'0'+y[i]-'0'+carry;
		carry=sum/10;
		tmp1[j++]=sum%10+'0';
	}
	if(carry!=0)
		tmp1[j]=carry+'0';
	strcpy(ans,rever(tmp1));
	return ans;
}

int main()
{
	char n[MAX];
	int m,i;
	//freopen("G:\\in.txt","r",stdin);
	while(scanf("%s%d",n,&m)!=EOF){
		cnt=0;    //务必在此初始化。。。
		for(i=0;i<m;i++){
			if(isPa(n)==0){
				strcpy(n,addstr(n,rever(n)));
				cnt++;
			}
			else
				break;
		}
		
		printf("%s\n%d\n",n,cnt);
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值