POJ 1789 Truck History

链接:http://poj.org/problem?id=1789

题目:

Truck History
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 16552 Accepted: 6363

Description

Advanced Cargo Movement, Ltd. uses trucks of different types. Some trucks are used for vegetable delivery, other for furniture, or for bricks. The company has its own code describing each type of a truck. The code is simply a string of exactly seven lowercase letters (each letter on each position has a very special meaning but that is unimportant for this task). At the beginning of company's history, just a single truck type was used but later other types were derived from it, then from the new types another types were derived, and so on. 

Today, ACM is rich enough to pay historians to study its history. One thing historians tried to find out is so called derivation plan -- i.e. how the truck types were derived. They defined the distance of truck types as the number of positions with different letters in truck type codes. They also assumed that each truck type was derived from exactly one other truck type (except for the first truck type which was not derived from any other type). The quality of a derivation plan was then defined as 
1/Σ(to,td)d(to,td)

where the sum goes over all pairs of types in the derivation plan such that t o is the original type and t d the type derived from it and d(t o,t d) is the distance of the types. 
Since historians failed, you are to write a program to help them. Given the codes of truck types, your program should find the highest possible quality of a derivation plan. 

Input

The input consists of several test cases. Each test case begins with a line containing the number of truck types, N, 2 <= N <= 2 000. Each of the following N lines of input contains one truck type code (a string of seven lowercase letters). You may assume that the codes uniquely describe the trucks, i.e., no two of these N lines are the same. The input is terminated with zero at the place of number of truck types.

Output

For each test case, your program should output the text "The highest possible quality is 1/Q.", where 1/Q is the quality of the best derivation plan.

Sample Input

4
aaaaaaa
baaaaaa
abaaaaa
aabaaaa
0

Sample Output

The highest possible quality is 1/3.

题意:

给出n个长度为7的字符串,两个字符串A、B的距离为:A和B相同位置上不同元素的个数,题目要求的是所有字符串的距离和的最小值。

解题思路:

这是一个典型的最小生成树问题,我们可以用Prim算法来解决这个问题。Prim算法的基本思路:有两个集合A,B,集合A放的是已经选中的点,B中放的是未选中的点。我们先选一个源点a放入A中,再从B中选一个点b放到A中,使得dis(A,b)(表示b与集合A的距离)最小,一直执行到B变成空集为止。


代码:

#include <iostream>
#include <cstring>
#include <string>
using namespace std;

#define INF 0x7fffffff
const int MAXN = 2010;
int n, lowcost[MAXN];
string str[MAXN];

void Init()
{
	memset(lowcost, 0, sizeof(lowcost));
	for(int i = 0; i < MAXN; i++) str[i] = "";
	for(int i = 0; i < n; i++) cin >> str[i];
}

int Transformation(int i, int j)
{
	int distance = 0;
	for(int k = 0; k < 7; k++)
	{
		if(str[i][k] != str[j][k])
		{
			distance++;
		}
	}
	return distance;
}

int Prim(int v)
{
	int ans = 0;
	for(int i = 0; i < n; i++)
	{
		lowcost[i] = Transformation(v, i);
	}
	
	for(int i = 0; i < n - 1; i++)
	{
		int min = INF, minpos = 0;
		for(int j = 0; j < n; j++)
		{
			if(lowcost[j] && lowcost[j] < min)
			{
				min    = lowcost[j];
				minpos = j;
			}
		}
		ans += min;
		lowcost[minpos] = 0;
		for(int j = 0; j < n; j++)
		{
			int dis = Transformation(minpos, j);
			if(lowcost[j] && dis < lowcost[j])
			{
				lowcost[j] = dis;
			} 
		}
	}
	return ans;
}

int main()
{
	std::ios::sync_with_stdio(false);

	while(cin >> n && n)
	{
		Init();
		cout << "The highest possible quality is 1/"
		 << Prim(0) << "." << endl;
	}
	
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值