ZOJ 3768 Continuous Login

链接:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemId=5231

题目:

Continuous Login

Time Limit: 2 Seconds       Memory Limit: 131072 KB       Special Judge

Pierre is recently obsessed with an online game. To encourage users to log in, this game will give users a continuous login reward. The mechanism of continuous login reward is as follows: If you have not logged in on a certain day, the reward of that day is 0, otherwise the reward is the previous day's plus 1.

On the other hand, Pierre is very fond of the number N. He wants to get exactly N points reward with the least possible interruption of continuous login.

Input

There are multiple test cases. The first line of input is an integer T indicates the number of test cases. For each test case:

There is one integer N (1 <= N <= 123456789).

Output

For each test case, output the days of continuous login, separated by a space.

This problem is special judged so any correct answer will be accepted.

Sample Input
4
20
19
6
9
Sample Output
4 4
3 4 2
3
2 3
Hint

20 = (1 + 2 + 3 + 4) + (1 + 2 + 3 + 4)

19 = (1 + 2 + 3) + (1 + 2 + 3 + 4) + (1 + 2)

6 = (1 + 2 + 3)

9 = (1 + 2) + (1 + 2 + 3)

Some problem has a simple, fast and correct solution.


解题思路:

连续登陆的天数最多不超过3组,具体是问什么,我也不清楚,听人家说是打表发现的规律。可以分成3种情况:1组、2组、3组,直接暴力枚举。


代码 :

/*wa*/ 
#include <iostream>
#include <cstring>
#include <map>
using namespace std;

const int MAXN = 50000;
map<int, int> m;
int a[MAXN];

int main()
{
	std::ios::sync_with_stdio(false);
	
	int t, n;
	for(int i = 0; i < MAXN; i++)
	{
		a[i]    = i * (i + 1) / 2;
		m[a[i]] = i;
	}
	
	while(cin >> t)
	{
		while(t--)
		{
			cin >> n;
			if(m[n])
			{
				cout << m[n] << endl;
			}
			else
			{
				int flag = 1;
				for(int i = 1; a[i] <= n; i++)
				{
					if(m[n - a[i]])
					{
						flag = 0;
						cout << i << " " << m[n-a[i]] << endl;
						break;
					}
				}
				
				if(flag)
				{
					for(int i = 1; a[i] <= n && flag; i++)
					{
						for(int j = 1; a[j] <= n && flag; j++)
						{
							if(m[n - a[i] - a[j]])
							{
								flag = 0;
								cout << i << " " << j << " " 
								<< m[n - a[i] - a[j]] << endl;
							}
						}
					}
				}
			}
		}
	}
	
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值