2010 Asia Fuzhou Regional Contest HDOJ 3694 Fermat Point in Quadrangle

链接:http://acm.hdu.edu.cn/showproblem.php?pid=3694

题目:

Fermat Point in Quadrangle

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1851    Accepted Submission(s): 319


Problem Description
In geometry the Fermat point of a triangle, also called Torricelli point, is a point such that the total distance from the three vertices of the triangle to the point is the minimum. It is so named because this problem is first raised by Fermat in a private letter. In the following picture, P 0  is the Fermat point. You may have already known the property that:

Alice and Bob are learning geometry. Recently they are studying about the Fermat Point.  

Alice: I wonder whether there is a similar point for quadrangle.

Bob: I think there must exist one.

Alice: Then how to know where it is? How to prove?

Bob: I don’t know. Wait… the point may hold the similar property as the case in triangle.  

Alice: It sounds reasonable. Why not use our computer to solve the problem? Find the Fermat point, and then verify your assumption.

Bob: A good idea.

So they ask you, the best programmer, to solve it. Find the Fermat point for a quadrangle, i.e. find a point such that the total distance from the four vertices of the quadrangle to that point is the minimum.
 

Input
The input contains no more than 1000 test cases.

Each test case is a single line which contains eight float numbers, and it is formatted as below:

x 1  y 1  x 2  y 2  x 3  y 3  x 4  y 4

x i, y i  are the x- and y-coordinates of the ith vertices of a quadrangle. They are float numbers and satisfy 0 ≤ x i  ≤ 1000 and 0 ≤ y i  ≤ 1000 (i = 1, …, 4).

The input is ended by eight -1.
 

Output
For each test case, find the Fermat point, and output the total distance from the four vertices to that point. The result should be rounded to four digits after the decimal point.
 

Sample Input
  
  
0 0 1 1 1 0 0 1 1 1 1 1 1 1 1 1 -1 -1 -1 -1 -1 -1 -1 -1
 

Sample Output
  
  
2.8284 0.0000
 

题意:

求四边形的费马点到四个顶点的距离之和。

解题思路:

费马点(到各顶点距离和最小的点)的基本应用。结论:对一个四边形,如果是凹四边形,费马点为凹点;如果是凸四边形,费马点为对角线的交点。


代码:

#include <cstdio>
#include <cmath>
#include <algorithm>
using namespace std;

#define ZERO 1e-6
struct P
{
    double x, y;
};
double ans;

/*求出a、b两点间的距离*/
double dis(P a, P b)
{
    return sqrt((a.x - b.x) * (a.x - b.x) + (a.y - b.y) * (a.y - b.y));
}

/*对角线ab与对角线cd相交时,求出最短距离和*/
void getcross(P a, P b, P c, P d)
{
    double a1 = b.y - a.y, b1 = a.x - b.x, c1 = a.x * b.y - b.x * a.y;
    double a2 = d.y - c.y, b2 = c.x - d.x, c2 = c.x * d.y - d.x * c.y;
    if(fabs(a1 * b2 - a2 * b1) < ZERO) return ;
    P p;
    p.y = (a2 * c1 - a1 * c2) / (a2 * b1 - a1 * b2);
    p.x = (b2 * c1 - b1 * c2) / (a1 * b2 - a2 * b1);
    ans = min(ans, dis(a, p) + dis(b, p) + dis(c, p) + dis(d, p));
}

int main()
{
    P a, b, c, d;
    while(~scanf("%lf%lf%lf%lf%lf%lf%lf%lf", &a.x, &a.y,
                 &b.x, &b.y, &c.x, &c.y, &d.x, &d.y))
     {
        if(fabs(a.x + 1) < ZERO) break;
        ans = 1e8;
        /*
        这是凹四边形的情况,
        凹点要么是a,要么是b,要么是c,要么是d
        */
        ans = min(ans, dis(b, a) + dis(c, a) + dis(d, a));
        ans = min(ans, dis(a, b) + dis(c, b) + dis(d, b));
        ans = min(ans, dis(a, c) + dis(b, c) + dis(d, c));
        ans = min(ans, dis(a, d) + dis(b, d) + dis(c ,d));
        /*
        这是凸四边形的情况;
        对角线要么是ab,要么ac,要么是ad
        */
        getcross(a, b, c, d);
        getcross(a, d, b, c);
        getcross(a, c, b, d);
        printf("%.4f\n", ans);
     }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
提供的源码资源涵盖了安卓应用、小程序、Python应用和Java应用等多个领域,每个领域都包含了丰富的实例和项目。这些源码都是基于各自平台的最新技术和标准编写,确保了在对应环境下能够无缝运行。同时,源码中配备了详细的注释和文档,帮助用户快速理解代码结构和实现逻辑。 适用人群: 这些源码资源特别适合大学生群体。无论你是计算机相关专业的学生,还是对其他领域编程感兴趣的学生,这些资源都能为你提供宝贵的学习和实践机会。通过学习和运行这些源码,你可以掌握各平台开发的基础知识,提升编程能力和项目实战经验。 使用场景及目标: 在学习阶段,你可以利用这些源码资源进行课程实践、课外项目或毕业设计。通过分析和运行源码,你将深入了解各平台开发的技术细节和最佳实践,逐步培养起自己的项目开发和问题解决能力。此外,在求职或创业过程中,具备跨平台开发能力的大学生将更具竞争力。 其他说明: 为了确保源码资源的可运行性和易用性,特别注意了以下几点:首先,每份源码都提供了详细的运行环境和依赖说明,确保用户能够轻松搭建起开发环境;其次,源码中的注释和文档都非常完善,方便用户快速上手和理解代码;最后,我会定期更新这些源码资源,以适应各平台技术的最新发展和市场需求。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值