POJ 1654 Area

链接:http://poj.org/problem?id=1654

题目:

Area
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 14292 Accepted: 4031

Description

You are going to compute the area of a special kind of polygon. One vertex of the polygon is the origin of the orthogonal coordinate system. From this vertex, you may go step by step to the following vertexes of the polygon until back to the initial vertex. For each step you may go North, West, South or East with step length of 1 unit, or go Northwest, Northeast, Southwest or Southeast with step length of square root of 2. 

For example, this is a legal polygon to be computed and its area is 2.5: 

Input

The first line of input is an integer t (1 <= t <= 20), the number of the test polygons. Each of the following lines contains a string composed of digits 1-9 describing how the polygon is formed by walking from the origin. Here 8, 2, 6 and 4 represent North, South, East and West, while 9, 7, 3 and 1 denote Northeast, Northwest, Southeast and Southwest respectively. Number 5 only appears at the end of the sequence indicating the stop of walking. You may assume that the input polygon is valid which means that the endpoint is always the start point and the sides of the polygon are not cross to each other.Each line may contain up to 1000000 digits.

Output

For each polygon, print its area on a single line.

Sample Input

4
5
825
6725
6244865

Sample Output

0
0
0.5
2

解题思路:

求多边形的面积,我们可以用叉积的性质来做。下图P1(x1,y1),P2(x2,y2),三角形OP1P2的面积等于 = 1/2 * 向量OP1与OP2叉积,即S = 1/2 * abs(x1 * y2 - x2 * y1);多边形可以分解为多个这样的三角形,多边形的面积即为这些三角形面积的和。这道题有几个注意点:1。可能是凹多边形,所以我们在求中间三角形面积的时候,不能加绝对值,要在最后求出累加面积后,再求绝对值,2.多边形面积可能会比较大,用double会出现精度问题,要使用整形,面积会超出int范围,要用long long, long long在求绝对值(用abs())的时候好像会编译错误,所以还是手工求绝对值,最后的面积在long long的值得基础上稍微处理一下就好。



代码:

#include <iostream>
#include <cstring>
using namespace std;

const int MAXN = 1000010;
char str[MAXN];

int fun(int x1, int y1, int x2, int y2)
{
	return x1 * y2 - x2 * y1;
}

int main()
{
	std::ios::sync_with_stdio(false);
	int t; cin >> t;
	
	while(t--)
	{
		cin >> str;
		int len = strlen(str);
		int x1 = 0, y1 = 0, x = 0, y = 0;
		long long area = 0;

		for(int i = 0; i < len; i++)
		{
			x1 = x, y1 = y;
			switch(str[i])
			{
				case '8': y++; break;
				case '2': y--; break;
				case '6': x++; break;
				case '4': x--; break;
				case '9': x++, y++; break;
				case '7': x--, y++; break;
				case '3': x++, y--; break;
				case '1': x--, y--; break;
				default: break;
			}
			area += fun(x1, y1, x, y);
		}
		
		area = area > 0 ? area : -area;
		if(0 == area % 2)
		{
			cout << area / 2 << endl;;
		}
		else
		{
			cout << area / 2 << ".5" << endl;
		}
	}

	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值