HDOJ 3555 Bomb

题目:

Bomb

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)
Total Submission(s): 8265    Accepted Submission(s): 2891


Problem Description
The counter-terrorists found a time bomb in the dust. But this time the terrorists improve on the time bomb. The number sequence of the time bomb counts from 1 to N. If the current number sequence includes the sub-sequence "49", the power of the blast would add one point.
Now the counter-terrorist knows the number N. They want to know the final points of the power. Can you help them?
 

Input
The first line of input consists of an integer T (1 <= T <= 10000), indicating the number of test cases. For each test case, there will be an integer N (1 <= N <= 2^63-1) as the description.

The input terminates by end of file marker.
 

Output
For each test case, output an integer indicating the final points of the power.
 

Sample Input
      
      
3 1 50 500
 

Sample Output
      
      
0 1 15
Hint
From 1 to 500, the numbers that include the sub-sequence "49" are "49","149","249","349","449","490","491","492","493","494","495","496","497","498","499", so the answer is 15.
 


传送门:点击打开链接

解题思路:

数位dp+记忆化搜索。

注意几个点:49,前面所有数都达到限制条件,并且包含49,返回1;492,在查找前两位变成49之后,第三位在满足限制条件的情况下应该返回1;4950,在查找前两位变成49之后,第三位取0,1,2,3,4都应该返回10,取5返回1。所以就有了下面tag和flag的判断限制条件。

代码:

/*数位dp*/
#include <cstdio>
#include <cstring>

typedef long long lint;
const int MAXN = 25;
int t, num[MAXN];
lint n, f[MAXN], dp[MAXN][MAXN];

//cur:当前位数,x:前一位的值,
//tag:在前面所有的数达到限制的条件下遇到49,flag是否达到限制
lint dfs(int cur, int x, bool tag, bool flag)
{
    //printf("%d %d\n", cur, x);
    if(tag && !flag) return f[cur+1];
    if(cur < 0)
    {
        if(tag && flag) return 1;
        return 0;
    }
    if(!flag && -1!=dp[cur][x])
    {
        return dp[cur][x];
    }
    lint ret = 0;
    int iend = flag ? num[cur] : 9;
    for(int i=0; i<=iend; ++i)
    {
        if(4==x && 9==i)
        {
            if(!flag)
            {
                ret += f[cur];
            }
            else
            {
                ret += dfs(cur-1, i, true, true);
            }
        }
        else
        {
            ret += dfs(cur-1, i, tag, flag&&(i==iend));
        }
    }
    if(!flag) dp[cur][x] = ret;
   // printf("%d %d %I64d %d\n", cur, x, ret, flag);
    return ret;
}

int main()
{
    memset(dp, -1, sizeof(dp));
    memset(f, 0, sizeof(f));
    f[0] = 1;
    for(int i=1; i<=18; ++i)
    {
        f[i] = 10*f[i-1];
    }
    scanf("%d", &t);
    while(t--)
    {
        scanf("%I64d", &n);
        int m = 0;
        lint k = n;
        while(k)
        {
            num[m++] = k%10;
            k /= 10;
        }
        printf("%I64d\n", dfs(m-1, -1, false, true));
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值