Bomb
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 131072/65536 K (Java/Others)
Total Submission(s): 11995 Accepted Submission(s): 4283
Problem Description
The counter-terrorists found a time bomb in the dust. But this time the terrorists improve on the time bomb. The number sequence of the time bomb counts from 1 to N. If the current number sequence includes the sub-sequence "49", the power of the blast would add one point.
Now the counter-terrorist knows the number N. They want to know the final points of the power. Can you help them?
Now the counter-terrorist knows the number N. They want to know the final points of the power. Can you help them?
Input
The first line of input consists of an integer T (1 <= T <= 10000), indicating the number of test cases. For each test case, there will be an integer N (1 <= N <= 2^63-1) as the description.
The input terminates by end of file marker.
The input terminates by end of file marker.
Output
For each test case, output an integer indicating the final points of the power.
Sample Input
3 1 50 500
Sample Output
0 1 15HintFrom 1 to 500, the numbers that include the sub-sequence "49" are "49","149","249","349","449","490","491","492","493","494","495","496","497","498","499", so the answer is 15.
题意:问你1-n之间含...49...的数字个数。
入门数位dp
AC代码:
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <cstdlib>
#include <algorithm>
#include <queue>
#include <stack>
#include <map>
#include <set>
#include <vector>
#include <string>
#define INF 1000000
#define eps 1e-8
#define MAXN (200000+10)
#define MAXM (100000+10)
#define Ri(a) scanf("%d", &a)
#define Rl(a) scanf("%lld", &a)
#define Rf(a) scanf("%lf", &a)
#define Rs(a) scanf("%s", a)
#define Pi(a) printf("%d\n", (a))
#define Pf(a) printf("%.2lf\n", (a))
#define Pl(a) printf("%lld\n", (a))
#define Ps(a) printf("%s\n", (a))
#define W(a) while((a)--)
#define CLR(a, b) memset(a, (b), sizeof(a))
#define MOD 1000000007
#define LL long long
#define lson o<<1, l, mid
#define rson o<<1|1, mid+1, r
#define ll o<<1
#define rr o<<1|1
#define PI acos(-1.0)
#pragma comment(linker, "/STACK:102400000,102400000")
#define fi first
#define se second
using namespace std;
typedef pair<int, int> pii;
LL dp[20][3];
//dp[i][0]: 不含49
//dp[i][1]: 不含49 最高位是9
//dp[i][2]: 含49
void Init()
{
dp[0][0] = 1LL; dp[0][1] = dp[0][2] = 0LL;
for(int i = 1; i <= 20; i++)
{
dp[i][0] = dp[i-1][0] * 10 - dp[i-1][1];
dp[i][1] = dp[i-1][0];
dp[i][2] = dp[i-1][2] * 10 + dp[i-1][1];
}
}
int bit[20];
LL Count(LL n)
{
int len = 0;
LL ans = 0;
while(n)
{
bit[++len] = n % 10;
n /= 10;
}
bit[++len] = 0; bool flag = false;
for(int i = len-1; i >= 1; i--)
{
ans += dp[i-1][2] * bit[i];//第i为填0 - bit[i]-1
if(flag) {ans += dp[i-1][0] * bit[i]; continue;}//高位已经不合法
if(bit[i] > 4) ans += dp[i-1][1];//填49
if(bit[i+1] == 4 && bit[i] == 9) flag = true;//高位不合法
}
if(flag) ans++;//自己
return ans;
}
int main()
{
Init();
int t; Ri(t);
W(t)
{
LL n; Rl(n);
Pl(Count(n));
}
return 0;
}