FatMouse and Cheese_hdu_1078(记忆化搜索).java

53 篇文章 0 订阅
29 篇文章 0 订阅

FatMouse and Cheese

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3695    Accepted Submission(s): 1469


Problem Description
FatMouse has stored some cheese in a city. The city can be considered as a square grid of dimension n: each grid location is labelled (p,q) where 0 <= p < n and 0 <= q < n. At each grid location Fatmouse has hid between 0 and 100 blocks of cheese in a hole. Now he's going to enjoy his favorite food.

FatMouse begins by standing at location (0,0). He eats up the cheese where he stands and then runs either horizontally or vertically to another location. The problem is that there is a super Cat named Top Killer sitting near his hole, so each time he can run at most k locations to get into the hole before being caught by Top Killer. What is worse -- after eating up the cheese at one location, FatMouse gets fatter. So in order to gain enough energy for his next run, he has to run to a location which have more blocks of cheese than those that were at the current hole.

Given n, k, and the number of blocks of cheese at each grid location, compute the maximum amount of cheese FatMouse can eat before being unable to move. 
 

Input
There are several test cases. Each test case consists of 

a line containing two integers between 1 and 100: n and k 
n lines, each with n numbers: the first line contains the number of blocks of cheese at locations (0,0) (0,1) ... (0,n-1); the next line contains the number of blocks of cheese at locations (1,0), (1,1), ... (1,n-1), and so on. 
The input ends with a pair of -1's. 
 

Output
For each test case output in a line the single integer giving the number of blocks of cheese collected. 
 

Sample Input
  
  
3 1 1 2 5 10 11 6 12 12 7 -1 -1
 

Sample Output
  
  
37
 

/*
 * 大大意思,有一个矩阵上,有好多奶酪,有一个XX从(0,0)开始出发,每次可以横着竖着走不超过k步,
 * 如果这个位置的奶酪数量大于以前位置,就可以到着把奶酪吃掉,也就是只能走比现在位置数大的位置
 * 问最多可以吃多少奶酪
 */

import java.util.Scanner;
public class Main{//记忆化搜索
	private static int a[][],b[][],n,m;
	public static void main(String[] args) {
		Scanner input=new Scanner(System.in);
		while(true){
			n=input.nextInt();
			m=input.nextInt();
			if(n==-1&&m==-1)
				break;
			a=new int[n+1][n+1];
			b=new int[n+1][n+1];
			for(int i=0;i<n;i++){
				for(int j=0;j<n;j++)
					a[i][j]=input.nextInt();
			}
			System.out.println(dfs(0,0));
		}
	}
	private static int dfs(int i, int j) {
		int max=0;//标记所有方向所有可走位置最大值
		if(b[i][j]>0)
			return b[i][j];
		for(int k=1;k<=m;k++){//判断走几步
			if(i+k<n&&a[i+k][j]>a[i][j]){//下搜第K位
				int sum=dfs(i+k,j);
				if(max<sum)
					max=sum;
			}
			if(i-k>=0&&a[i-k][j]>a[i][j]){//上搜第K位
				int sum=dfs(i-k,j);
				if(max<sum)
					max=sum;
			}
			if(j+k<n&&a[i][j+k]>a[i][j]){//又搜第K位
				int sum=dfs(i,j+k);
				if(max<sum)
					max=sum;
			}
			if(j-k>=0&&a[i][j-k]>a[i][j]){//左搜第K位
				int sum=dfs(i,j-k);
				if(max<sum)
					max=sum;
			}
		}
		return b[i][j]=max+a[i][j];//返回,要加上本身位置哦
	}
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值