hdu FatMouse and Cheese(dp)

FatMouse and Cheese

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2760    Accepted Submission(s): 1064


Problem Description
FatMouse has stored some cheese in a city. The city can be considered as a square grid of dimension n: each grid location is labelled (p,q) where 0 <= p < n and 0 <= q < n. At each grid location Fatmouse has hid between 0 and 100 blocks of cheese in a hole. Now he's going to enjoy his favorite food.

FatMouse begins by standing at location (0,0). He eats up the cheese where he stands and then runs either horizontally or vertically to another location. The problem is that there is a super Cat named Top Killer sitting near his hole, so each time he can run at most k locations to get into the hole before being caught by Top Killer. What is worse -- after eating up the cheese at one location, FatMouse gets fatter. So in order to gain enough energy for his next run, he has to run to a location which have more blocks of cheese than those that were at the current hole.

Given n, k, and the number of blocks of cheese at each grid location, compute the maximum amount of cheese FatMouse can eat before being unable to move. 
 

Input
There are several test cases. Each test case consists of 

a line containing two integers between 1 and 100: n and k 
n lines, each with n numbers: the first line contains the number of blocks of cheese at locations (0,0) (0,1) ... (0,n-1); the next line contains the number of blocks of cheese at locations (1,0), (1,1), ... (1,n-1), and so on. 
The input ends with a pair of -1's. 
 

Output
For each test case output in a line the single integer giving the number of blocks of cheese collected. 
 

Sample Input
  
  
3 1 1 2 5 10 11 6 12 12 7 -1 -1
 

Sample Output
  
  
37
 

Source


dp题
很容易想到状态是矩阵的坐标

需要突破的有两点
A. dp的顺序,为了确保状态转移时所利用的dp值是最优的,可以对map[i][j]进行从小到大的排序
这样,每次能到达dp[x][y]的只有map值比它小的,而这个值在前面已经被确定为最优了,所以
保证了正确性
B. 要判断并标记某点是否可达,否则每次状态转移时可能会把不可能存在的路径考虑进去
因为map值比a点小的值的点b,可能是不可能到达的,所以在对a点dp值进行更新时,不能考虑把b点考虑进去
详见代码

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;

int map[105][105];
int dp[105][105];
bool can[105][105];
struct Node{
    int num;
    int x,y;
}od[10005];

int cmp(Node a,Node b){
    return a.num < b.num;
}

int main(){
    int n,k;
    int i,j,m;
    int x,y;
    int maxn,ans;

    while(scanf("%d%d",&n,&k) && n != -1 && k != -1){
        memset(dp,0,sizeof(dp));
        memset(can,0,sizeof(can));
        for(i = 0;i < n;i++){
            for(j = 0;j < n;j++){
                scanf("%d",&map[i][j]);
                od[i * n + j].num = map[i][j];
                od[i * n + j].x = i;
                od[i * n + j].y = j;
            }
        }
        sort(od,od + n*n,cmp);
        dp[0][0] = map[0][0];
        ans = dp[0][0];
        for(i = 0;i < n * n;i++){
            x = od[i].x;
            y = od[i].y;
            maxn = -1;
            for(m = 1;m <= k;m++){
                if(x - m >= 0 && map[x-m][y] < map[x][y] && !can[x-m][y]){
                    if(dp[x-m][y] > maxn)
                        maxn = dp[x-m][y];
                }
                if(x + m < n && map[x+m][y] < map[x][y] && !can[x+m][y]){
                    if(dp[x+m][y] > maxn)
                        maxn = dp[x+m][y];
                }
                if(y - m >= 0 && map[x][y - m] < map[x][y] && !can[x][y-m]){
                    if(dp[x][y-m] > maxn)
                        maxn = dp[x][y-m];
                }
                if(y + m < n && map[x][y + m] < map[x][y] && !can[x][y+m]){
                    if(dp[x][y+m] > maxn)
                        maxn = dp[x][y+m];
                }
            }
            if(maxn == -1){
                if(!x && !y)
                    continue;
                can[x][y] = 1;
                dp[x][y] = 0;
                continue;
            }
            dp[x][y] = maxn + map[x][y];
            ans = max(ans,dp[x][y]);
        }
        printf("%d\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值