poj2311 Cutting Game

67 篇文章 1 订阅
Cutting Game
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 2546 Accepted: 931

Description

Urej loves to play various types of dull games. He usually asks other people to play with him. He says that playing those games can show his extraordinary wit. Recently Urej takes a great interest in a new game, and Erif Nezorf becomes the victim. To get away from suffering playing such a dull game, Erif Nezorf requests your help. The game uses a rectangular paper that consists of W*H grids. Two players cut the paper into two pieces of rectangular sections in turn. In each turn the player can cut either horizontally or vertically, keeping every grids unbroken. After N turns the paper will be broken into N+1 pieces, and in the later turn the players can choose any piece to cut. If one player cuts out a piece of paper with a single grid, he wins the game. If these two people are both quite clear, you should write a problem to tell whether the one who cut first can win or not.

Input

The input contains multiple test cases. Each test case contains only two integers W and H (2 <= W, H <= 200) in one line, which are the width and height of the original paper.

Output

For each test case, only one line should be printed. If the one who cut first can win the game, print "WIN", otherwise, print "LOSE".

Sample Input

2 2
3 2
4 2

Sample Output

LOSE
LOSE
WIN
注意,如果,有个人切成了1*n n*1那个这个人必败,所以每一个人,在切的时候,都会去避开,这样,我们找到前驱,求sg函数值即可!
#include <iostream>
#include <stdio.h>
#include <string.h>
using namespace std;
int dp[250][250];
int getsg(int w,int h){
    if(dp[w][h]!=-1)return dp[w][h];
    bool vis[10000];
    memset(vis,0,sizeof(vis));
    for(int i=2;i<=w-i;i++){
        dp[i][h]=getsg(i,h);
        dp[w-i][h]=getsg(w-i,h);
        vis[dp[i][h]^dp[w-i][h]]=true;
    }
    for(int i=2;i<=h-i;i++){
        dp[w][i]=getsg(w,i);
        dp[w][h-i]=getsg(w,h-i);
        vis[dp[w][i]^dp[w][h-i]]=true;
    }
    for(int i=0;;i++)
    if(!vis[i])
    return dp[w][h]=i;
}
int main()
{
    int w,h;
    memset(dp,-1,sizeof(dp));
    while(scanf("%d%d",&w,&h)!=EOF){
        if(getsg(w,h))printf("WIN\n");
        else printf("LOSE\n");
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值