过剩数

过剩数

Time Limit : 3000/1000ms (Java/Other)   Memory Limit : 65535/32768K (Java/Other)
Total Submission(s) : 36   Accepted Submission(s) : 16
Font: Times New Roman | Verdana | Georgia
Font Size:  

Problem Description

An abundant number is a positive integer n for which Sigma(n) – 2n > 0, Where Sigma(n) is defined as the sum of all the divisors of n. And the quantity Sigma(n) – 2n is called abundance. 
Given the range of n, you should find out the maximum abundance value that can be reached. For example, if the range is [10,12], then the only abundant number is 12, and the maximum abundance value is Sigma(12) – 2 * 12 = 4. 

Input

Input may contain several test cases. The first line is a positive integer, T (T<=20), the number of test cases below. Each test case contains two positive integers x, y, (1<= x <= y <= 1024), indicating the range of n.

Output

For each test case, output the maximum abundance value that can be reached in the range of n. If there is no abundant number n in the given range, simply output -1.

Sample Input

3
1 1
10 12
1 1024

Sample Output

-1
4
1208
#include<stdio.h>
#include<iostream>
using namespace std;
int p[1200];
int main()
{
  p[0]=1;
	int a,b,n,i,j,t;
	for(i=1;i<1100;i++)
	{
	  for(j=1;j<=i;j++)
	  {
		  if(i%j==0)
			  p[i]+=j;
	  }
	  if(p[i]<=2*i)  p[i]=-1;
	  else 
		  p[i]=p[i]-2*i;
     }
while(scanf("%d\n",&t)!=EOF)
{


	while(t--)
	{
		n=0;
		scanf("%d%d",&a,&b);
	 for(i=a;i<=b;i++)
		{
           if(n<=p[i]) 
		   n=p[i];
		   if(n==0)  n=-1;
		}
       printf("%d\n",n);
	  }
}
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值