Sicily 1691. Abundance

Time Limit: 1 secs, Memory Limit: 32 MB

Description

An abundant number is a positive integer n for which Sigma(n) – 2n > 0, Where Sigma(n) is defined as the sum of all the divisors of n. And the quantity Sigma(n) – 2n is called abundance.
Given the range of n, you should find out the maximum abundance value that can be reached. For example, if the range is [10,12], then the only abundant number is 12, and the maximum abundance value is Sigma(12) – 2 * 12 = 4.
Input

Input may contain several test cases. The first line is a positive integer, T (T<=20), the number of test cases below. Each test case contains two positive integers x, y, (1<= x <= y <= 1024), indicating the range of n.
Output

For each test case, output the maximum abundance value that can be reached in the range of n. If there is no abundant number n in the given range, simply output -1.
Sample Input

3
1 1
10 12
1 1024
Sample Output

-1
4
1208


(^-^)V Just Do It!

#include <algorithm>
#include <iostream>
#include <vector>
#include <cmath>

using namespace std;

int getSumOfDivisors(int num)
{
    int sum = 0;
    for (int i = 1; i < sqrt(num); i++)
        if (num % i == 0)
            sum = sum + num / i + i;
    if (sqrt(num) * sqrt(num) == num)
        sum += sqrt(num);
    return sum;
}

int main()
{
    int T, begin, end;
    vector<int> v;
    cin >> T;
    while (T--)
    {
        v.clear();
        cin >> begin >> end;
        for (int i = begin; i <= end; i++)
            if (getSumOfDivisors(i) - 2 * i > 0)
                v.push_back(getSumOfDivisors(i) - 2 * i);
        if (v.size() == 0)
            cout << -1 << endl;
        else
        {
            sort(v.begin(), v.end());
            cout << v[v.size() - 1] << endl;
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值