POJ 1840:Eqs 哈希求解五元方程

Eqs
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 14169 Accepted: 6972

Description

Consider equations having the following form: 
a1x1 3+ a2x2 3+ a3x3 3+ a4x4 3+ a5x5 3=0 
The coefficients are given integers from the interval [-50,50]. 
It is consider a solution a system (x1, x2, x3, x4, x5) that verifies the equation, xi∈[-50,50], xi != 0, any i∈{1,2,3,4,5}. 

Determine how many solutions satisfy the given equation. 

Input

The only line of input contains the 5 coefficients a1, a2, a3, a4, a5, separated by blanks.

Output

The output will contain on the first line the number of the solutions for the given equation.

Sample Input

37 29 41 43 47

Sample Output

654

给定方程是a1x13+ a2x23+ a3x33+ a4x43+ a5x53=0 ,给了a1,a2,a3,a4,a5。求解 解的数量。x都在-50到50之间。

暴搜肯定GG,就得把方程变形将a1x13+ a2x23  移到方程左边,作为结果,然后暴搜x3,x4,x5。时间复杂度就降下来了。 

代码:

#include <iostream>
#include <algorithm>
#include <cmath>
#include <vector>
#include <string>
#include <cstring>
#pragma warning(disable:4996)
using namespace std;

short hash1[25000000];

int main()
{	
	int a1, a2, a3, a4, a5;
	int x1, x2, x3, x4, x5;
	int temp;
	long long sum;

	scanf("%d%d%d%d%d",&a1,&a2,&a3,&a4,&a5);

	memset(hash1, 0, sizeof(hash1));
	for (x1 = -50; x1 <= 50; x1++)
	{
		if (x1 == 0)continue;
		for (x2 = -50; x2 <= 50; x2++)
		{
			if (x2 == 0)continue;
			
			temp = -1*(a1*x1*x1*x1 + a2*x2*x2*x2);

			if (temp < 0)
			{
				temp += 25000000;
			}
			hash1[temp]++;
		}
	}
	sum = 0;
	for (x3 = -50; x3 <= 50; x3++)
	{
		if (x3 == 0)continue;
		for (x4 = -50; x4 <= 50; x4++)
		{
			if (x4 == 0)continue;
			for (x5 = -50; x5 <= 50; x5++)
			{
				if (x5 == 0)continue;
				
				temp = a3*x3*x3*x3 + a4*x4*x4*x4 + a5*x5*x5*x5;
				
				if (temp < 0)
				{
					temp += 25000000;
				}
				if (temp >= 0 && temp < 25000000) 
				{
					sum += hash1[temp];
				}
			}
		}
	}
	cout << sum << endl;
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值