ACM: 哈希暴力求解 哈希题 poj 184…

该博客介绍了如何使用哈希暴力方法解决ACM竞赛中的一道题目,该题目涉及一个三元三次方程。博主通过先计算x1, x2, x3的值并存入哈希表,然后计算x4, x5的值来统计解的数量。代码示例给出了详细的解题过程。" 113071673,10541542,FFmpeg安装教程:源码编译与二进制包,"['FFmpeg', '视频处理', '音视频开发', '命令行工具', '软件安装']
摘要由CSDN通过智能技术生成

                                                                     Eqs

Description

Consider equations having the following form:
a1x13+ a2x23+ a3x33+ a4x43+ a5x53=0
The coefficients are given integers from the interval [-50,50].
It is consider a solution a system (x1, x2, x3, x4, x5) that verifies the equation, xi∈[-50,50], xi != 0, any i∈{1,2,3,4,5}.

Determine how many solutions satisfy the given equation.

Input

The only line of input contains the 5 coefficients a1, a2, a3, a4, a5, separated by blanks.

Output

The output will contain on the first line the number of the solutions for the given equation.

Sample Input

37 29 41 43 47

Sample Output

654

题意: a1x13+ a2x23+ a3x33+ a4x43+ a5x53=0 求方程有多少个解.

 

解题思路:

                1. 先求解x1,x2,x3的值的个数保存在hash中.

                2. 再求解x4,x5的值统计就可以得出解的个数.

 

代码:

#include <cstdio>
#include <iostream>
#include <cstring>
#include <cmath>
using namespace std;
const int MAX = 31250000;   //5*50^4*2

char hash[MAX*2+100];
int a,b,c,d,e;
int ans1, ans2;
int result;

int main()
{
//    freopen("input.txt","r",stdin);
    while(scanf("%d %d %d %d %d",&a,&b,&c,&d,&e) != EOF)
    {
        result = 0;
        memset(hash,0,sizeof(hash));
        ans1 = 0;
        ans2 = 0;
        for(int i = -50; i <= 50; ++i)
        {
            for(int j = -50; j <= 50; ++j)
            {
                for(int k = -50; k <= 50; ++k)
                {
                    if(i != 0 && j != 0 && k != 0)
                    {
                        ans1 = (a*i*i*i + b*j*j*j + c*k*k*k);
                        hash[ans1+MAX]++;
                    }
                }
            }
        }
        
        for(int i = -50; i <= 50; ++i)
        {
            for(int j = -50; j <= 50; ++j)
            {
                if(i != 0 && j != 0)
                {
                    ans2 = -(d*i*i*i + e*j*j*j);
                    result += hash[MAX+ans2];
                }
            }
        }
        
        printf("%d\n",result);
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值