[回溯]Graph Coloring UVA193



 Graph Coloring 

You are to write a program that tries to find an optimal coloring for a given graph. Colors are applied to the nodes of the graph and the only available colors are black and white. The coloring of the graph is called optimal if a maximum of nodes is black. The coloring is restricted by the rule that no two connected nodes may be black.

  figure22 
Figure: An optimal graph with three black nodes

Input and Output

The graph is given as a set of nodes denoted by numbers tex2html_wrap_inline33 , tex2html_wrap_inline35 , and a set of undirected edges denoted by pairs of node numbers tex2html_wrap_inline37 , tex2html_wrap_inline39 . The input file contains m graphs. The number m is given on the first line. The first line of each graph contains n and k, the number of nodes and the number of edges, respectively. The following k lines contain the edges given by a pair of node numbers, which are separated by a space.

The output should consists of 2m lines, two lines for each graph found in the input file. The first line of should contain the maximum number of nodes that can be colored black in the graph. The second line should contain one possible optimal coloring. It is given by the list of black nodes, separated by a blank.

Sample Input

1
6 8
1 2
1 3
2 4
2 5
3 4
3 6
4 6
5 6

Sample Output

3
1 4 5


这道题需要换一个思路去解题,设想一开始所有的结点都是白色,我们负责把结点染黑就可以,然后回溯求解,在这个基础上再剪枝,这样下来就方便很多,比分别染黑染白要简单很多。

#include<iostream>
#include<cstring>

using namespace std;

int maxnum,n;
int color[110],black[110],grid[110][110];

void dfs(int pos,int num)
{
    int i,tag=1;
    if(num>maxnum)
    {
        maxnum=num;
        for(i=1;i<=n;i++)
        {
            black[i]=color[i];
        }
    }
    if(num+n-pos+1<=maxnum) return;
    for(i=1;i<=n;i++)
    {
        if(grid[i][pos]==1&&color[i]==1)
        {
            tag=0;
            break;
        }
    }
    if(tag)
    {
        color[pos]=1;
        dfs(pos+1,num+1);
        color[pos]=0;
    }
    dfs(pos+1,num);
    return;
}

int main()
{
    int t,m;
    cin>>t;
    while(t--)
    {
        cin>>n>>m;
        int i,j,x,y;
        memset(grid,0,sizeof(grid));
        memset(color,0,sizeof(color));
        for(i=1;i<=m;i++)
        {
            cin>>x>>y;
            grid[x][y]=grid[y][x]=1;
        }
        maxnum=0;
        dfs(1,0);
        cout<<maxnum<<endl;
        int s=0;
        for(i=1;i<=n;i++)
        {
            if(black[i])
            {
                s++;
                cout<<i;
                if(s==maxnum)
                {
                    cout<<endl;
                }
                else
                {
                    cout<<" ";
                }
            }
        }
    }
    return 0;
}
Python网络爬虫与推荐算法新闻推荐平台:网络爬虫:通过Python实现新浪新闻的爬取,可爬取新闻页面上的标题、文本、图片、视频链接(保留排版) 推荐算法:权重衰减+标签推荐+区域推荐+热点推荐.zip项目工程资源经过严格测试可直接运行成功且功能正常的情况才上传,可轻松复刻,拿到资料包后可轻松复现出一样的项目,本人系统开发经验充足(全领域),有任何使用问题欢迎随时与我联系,我会及时为您解惑,提供帮助。 【资源内容】:包含完整源码+工程文件+说明(如有)等。答辩评审平均分达到96分,放心下载使用!可轻松复现,设计报告也可借鉴此项目,该资源内项目代码都经过测试运行成功,功能ok的情况下才上传的。 【提供帮助】:有任何使用问题欢迎随时与我联系,我会及时解答解惑,提供帮助 【附带帮助】:若还需要相关开发工具、学习资料等,我会提供帮助,提供资料,鼓励学习进步 【项目价值】:可用在相关项目设计中,皆可应用在项目、毕业设计、课程设计、期末/期中/大作业、工程实训、大创等学科竞赛比赛、初期项目立项、学习/练手等方面,可借鉴此优质项目实现复刻,设计报告也可借鉴此项目,也可基于此项目来扩展开发出更多功能 下载后请首先打开README文件(如有),项目工程可直接复现复刻,如果基础还行,也可在此程序基础上进行修改,以实现其它功能。供开源学习/技术交流/学习参考,勿用于商业用途。质量优质,放心下载使用。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值