uva 193 Graph Coloring(DFS)

942 篇文章 2 订阅
223 篇文章 1 订阅

 Graph Coloring 

You are to write a program that tries to find an optimal coloring for a given graph. Colors are applied to the nodes of the graph and the only available colors are black and white. The coloring of the graph is called optimal if a maximum of nodes is black. The coloring is restricted by the rule that no two connected nodes may be black.

  figure22 
Figure: An optimal graph with three black nodes

Input and Output

The graph is given as a set of nodes denoted by numbers tex2html_wrap_inline33 , tex2html_wrap_inline35 , and a set of undirected edges denoted by pairs of node numbers tex2html_wrap_inline37 , tex2html_wrap_inline39 . The input file contains m graphs. The number m is given on the first line. The first line of each graph contains n and k, the number of nodes and the number of edges, respectively. The following k lines contain the edges given by a pair of node numbers, which are separated by a space.

The output should consists of 2m lines, two lines for each graph found in the input file. The first line of should contain the maximum number of nodes that can be colored black in the graph. The second line should contain one possible optimal coloring. It is given by the list of black nodes, separated by a blank.

Sample Input

1
6 8
1 2
1 3
2 4
2 5
3 4
3 6
4 6
5 6

Sample Output

3
1 4 5
题目大意:给出一些相邻的点,然后要给点染色,染成黑色,要求相邻的点不能同时染成黑色,问最多染几个点,并且输出字典序最大的。

解题思路:读入点之间的关系后,单纯的用DFS去搜索,直到收索到最后一个点。

#include <stdio.h> 
#include <string.h> 
#define N 105
int g[N][N], vis[N], rec[N];
int n, n_rec, m;

int judge(int k, int sum){
    for (int i = 0; i <= sum; i++)
	if (g[k][vis[i]])
	    return 1;
    return 0;
}

void DFS(int k, int cnt){
    vis[cnt] = k;
    for (int i = k + 1; i <= n; i++){
	if (judge(i, cnt))  continue;
	DFS(i, cnt + 1);
    }

    if (cnt >= n_rec){
	n_rec = cnt;
	memcpy(rec, vis, sizeof(vis));
    }
}

int main(){
    int t;
    scanf("%d", &t);
    while (t--){
	// Init;
	memset(g, 0, sizeof(g));
	memset(rec, 0, sizeof(rec));
	n_rec = 0;

	// Read;
	scanf("%d%d", &n, &m);
	for (int i = 0; i < m; i++){
	    int a, b;
	    scanf("%d%d", &a, &b);
	    g[a][b] = g[b][a] = 1;
	}

	for (int i = 1; i <= n; i++){
	    memset(vis, 0, sizeof(vis));
	    DFS(i, 0);
	}

	printf("%d\n", n_rec + 1);
	for (int i = 0; i < n_rec; i++)
	    printf("%d ", rec[i]);
	printf("%d\n", rec[n_rec]);
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值