UVA 193 Graph Coloring

 Graph Coloring 

You are to write a program that tries to find an optimal coloring for a given graph. Colors are applied to the nodes of the graph and the only available colors are black and white. The coloring of the graph is called optimal if a maximum of nodes is black. The coloring is restricted by the rule that no two connected nodes may be black.

  figure22 
Figure: An optimal graph with three black nodes

Input and Output

The graph is given as a set of nodes denoted by numbers tex2html_wrap_inline33 , tex2html_wrap_inline35 , and a set of undirected edges denoted by pairs of node numbers tex2html_wrap_inline37 , tex2html_wrap_inline39 . The input file contains m graphs. The number m is given on the first line. The first line of each graph contains n and k, the number of nodes and the number of edges, respectively. The following k lines contain the edges given by a pair of node numbers, which are separated by a space.

The output should consists of 2m lines, two lines for each graph found in the input file. The first line of should contain the maximum number of nodes that can be colored black in the graph. The second line should contain one possible optimal coloring. It is given by the list of black nodes, separated by a blank.

Sample Input

1
6 8
1 2
1 3
2 4
2 5
3 4
3 6
4 6
5 6

Sample Output

3
1 4 5

题意:给定n个点和m种连接方式。每个点可以染成黑色和白色。规则是相连的点。不能都染成黑色。。

思路:深搜回溯。先判断一个点如果周围没有黑点。就可以染黑或白。如果有黑点。就只能染白了

#include <stdio.h>
#include <string.h>

int m;
int n, k;
int x, y;
int map[105][105];
int color[105];
int vis[105];
int max;
int out[105];

int judge(int dian)
{
    for (int i = 1; i <= n; i ++)
	if (map[dian][i] == 1 && color[i] == 1 && i != dian)
	    return 0;
    return 1;
}
void dfs(int dian, int num)
{
    if (dian == n + 1)
    {
	if (max < num)
	{
	    max = num;
	    for (int i = 1; i <= n; i ++)
		out[i] = color[i];
	}
	return;
    }
    if (judge(dian))
    {
	color[dian] = 1;
	dfs(dian + 1, num + 1);
	color[dian] = 0;
	dfs(dian + 1, num);
    }
    else
    {
	color[dian] = 0;
	dfs(dian + 1, num);
    }
}
int main()
{
    scanf("%d", &m);
    while (m --)
    {
	max = 0;
	memset(map, 0, sizeof(map));
	memset(color, 0, sizeof(color));
	memset(vis, 0, sizeof(vis));
	scanf("%d%d", &n, &k);
	for (int i = 0; i < k; i ++)
	{
	    scanf("%d%d", &x, &y);
	    map[x][y] = map[y][x] = 1;
	}
	dfs(1, 0);
	int bo = 0;
	printf("%d\n", max);
	for (int i = 1; i <= n; i ++)
	{
	    if (out[i])
	    {
		if (bo == 0)
		{
		    bo = 1;
		    printf("%d", i);
		}
		else
		{
		    printf(" %d", i);
		}
	    }
	}
	printf("\n");
    }
    return 0;    
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值