[动态规划]UVA111 - History Grading


 History Grading 

Background

Many problems in Computer Science involve maximizing some measure according to constraints.

Consider a history exam in which students are asked to put several historical events into chronological order. Students who order all the events correctly will receive full credit, but how should partial credit be awarded to students who incorrectly rank one or more of the historical events?

Some possibilities for partial credit include:

  1. 1 point for each event whose rank matches its correct rank
  2. 1 point for each event in the longest (not necessarily contiguous) sequence of events which are in the correct order relative to each other.

For example, if four events are correctly ordered 1 2 3 4 then the order 1 3 2 4 would receive a score of 2 using the first method (events 1 and 4 are correctly ranked) and a score of 3 using the second method (event sequences 1 2 4 and 1 3 4 are both in the correct order relative to each other).

In this problem you are asked to write a program to score such questions using the second method.

The Problem

Given the correct chronological order of n events tex2html_wrap_inline34 as tex2html_wrap_inline36 where tex2html_wrap_inline38 denotes the ranking of event i in the correct chronological order and a sequence of student responses tex2html_wrap_inline42 where tex2html_wrap_inline44 denotes the chronological rank given by the student to event i; determine the length of the longest (not necessarily contiguous) sequence of events in the student responses that are in the correct chronological order relative to each other.

The Input

The first line of the input will consist of one integer n indicating the number of events with tex2html_wrap_inline50 . The second line will contain nintegers, indicating the correct chronological order of n events. The remaining lines will each consist of n integers with each line representing a student's chronological ordering of the n events. All lines will contain n numbers in the range tex2html_wrap_inline60 , with each number appearing exactly once per line, and with each number separated from other numbers on the same line by one or more spaces.

The Output

For each student ranking of events your program should print the score for that ranking. There should be one line of output for each student ranking.

Sample Input 1

4
4 2 3 1
1 3 2 4
3 2 1 4
2 3 4 1

Sample Output 1

1
2
3

Sample Input 2

10
3 1 2 4 9 5 10 6 8 7
1 2 3 4 5 6 7 8 9 10
4 7 2 3 10 6 9 1 5 8
3 1 2 4 9 5 10 6 8 7
2 10 1 3 8 4 9 5 7 6

Sample Output 2

6
5
10
9

题意:

在资讯科学中有一些是关于在某些条件限制下,找出一些计算的最大值。

以历史考试来说好了,学生被要求对一些历史事件根据其发生的年代顺序来排列。所有事件顺序都正确的学生无疑的可以得满分。但是那些没有全对的人又该如何给分呢?以下有2种可能的给分方式:

  1. 每个与标准答案的顺序相同的事件得1分
  2. 每个在最长(但不一定要连续)的序列事件中,其相对的顺序亦可以在标准答案发现者,每个事件得1分。

举例说明:如果有4个事件其发生时间的顺序依次是1 2 3 4(就是标准答案啦,意思是第1个事件发生顺序为1,第2个事件发生的顺序为2,.... ..)。所以如果学生回答此4个事件发生的顺序依次是1 3 2 4的话,根据上面第1种方法可以得2分(第1个及第4个事件)。但是如果以上面第2种方法可以得3分(1 2 4或者1 3 4其相对的顺序可以在标准答案发现)

在本问题中,请你写一个程式以第2个方法算出学生该得多少分

思路:输入有点绕,需要对输入做一些改变,这是典型的,最长公共子序列问题。

#include<iostream>
#include<cstring>

using namespace std;

int order[30];
int node[30],arry[30][30];

int main()
    {
        int num;
        cin>>num;
        int i,j,k;
        for(i=0;i<num;i++)
            {
                cin>>k;
                order[k-1]=i+1;
            }
        while(cin>>k)
            {
                node[k-1]=1;
                for(i=1;i<num;i++)
                    {
                        cin>>k;
                        node[k-1]=i+1;
                    }
                memset(arry,0,sizeof(arry));
                for(i=1;i<=num;i++)
                    {
                        for(j=1;j<=num;j++)
                            {
                                if(node[i-1]==order[j-1]) arry[i][j]=arry[i-1][j-1]+1;
                                else arry[i][j]=max(arry[i-1][j],arry[i][j-1]);
                            }
                    }
                cout<<arry[num][num]<<endl;
            }
        return 0;
    }


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值