POJ 3694 Network (求割边 + LCA)

该博客探讨了如何解决POJ 3694问题,即在无向图中加入一条边后如何计算剩余的桥数量。通过求割边、缩点、DFS找父节点和LCA(最近公共祖先)算法,博主提供了清晰的解题思路。虽然可以不使用缩点,但使用缩点的方法会使程序复杂。文章强调,在LCA过程中,原图的割边状态能指示边是否转化为普通边。
摘要由CSDN通过智能技术生成

这道题是一个无向图,询问加入某条边后,问图内剩余的桥有多少。

这题的大概思路就是,先求割边并标记,然后缩点,形成一棵树,然后把这颗树上各个结点的父结点用dfs求出来,再然后就是LCA了,因为加入某条边后,树内会形成一个圈,这个圈上所有的边将不再是桥,可以发现跟LCA的关联。

求LCA用裸的方法就行,比较直观些,也好操作。

实际上,这道题也不一定要缩点,如果用缩点的思路来做的话,程序将十分麻烦。可以直接根据dfn值来进行LCA。因为,我们观察low[v] > dfn[u]这个条件,代表的意思就是v无法通过回边或者通过子女到达比u点更靠前的点,那么我们只需要标记v点即可表明割边。在进行LCA时,由于树的组成就是原图中的割边,所以在原图中,根据这个标记来判断是否将割边被转化为了普通边。

Network
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 7040 Accepted: 2521

Description

A network administrator manages a large network. The network consists of N computers and M links between pairs of computers. Any pair of computers are connected directly or indirectly by successive links, so data can be transformed between any two computers. The administrator finds that some links are vital to the network, because failure of any one of them can cause that data can't be transformed between some computers. He call such a link a bridge. He is planning to add some new links one by one to eliminate all bridges.

You are to help the administrator by reporting the number of bridges in the network after each new link is added.

Input

The input consists of multiple test cases. Each test case starts with a line containing two integers N(1 ≤ N ≤ 100,000) and M(N - 1 ≤ M ≤ 200,000).
Each of the following M lines contains two integers A and B ( 1≤ A ≠ B ≤ N), which indicates a link between computer A and B. Computers are numbered from 1 to N. It is guaranteed that any two computers are connected in the initial network.
The next line contains a single integer Q ( 1 ≤ Q ≤ 1,000), which is the number of new links the administrator plans to add to the network one by one.
The i-th line of the following Q lines contains two integer A and B (1 ≤ A ≠ B ≤ N), which is the i-th added new link connecting computerA and B.

The last test case is followed by a line containing two zeros.

Output

For each test case, print a line containing the test case number( beginning with 1) and Q lines, the i-th of which contains a integer indicating the number of bridges in the network after the first i new links are added. Print a blank line after the output for each test case.

Sample Input

3 2
1 2
2 3
2
1 2
1 3
4 4
1 2
2 1
2 3
1 4
2
1 2
3 4
0 0

Sample Output

Case 1:
1
0

Case 2:
2
0

Source

[Submit]   [Go Back]   [Status]   [Discuss]

/*
ID:huang_l1
LANG:C++
PROG:combo
*/
#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;
#define prt(k) cout<<#k" = "<<k<<endl;
const int N = 100005;
int head[N], n, m, Q, dep[N], len[N]; /// len[i] 表示 i 到根距离
struct Edge
{
    int to, next, w;
}e[N << 1];
int f[N][22];
int mm;
void add(int u, int v, int w=1)
{
    e[mm] = (Edge){v, head[u], w};
    head[u] = mm++;
}
int cur, cnt;
int dfn[N], low[N], bridge[N], p[N], fa[N];
///p[i] -- i 的父亲
///bridge[i] -- (i, p[i]) 这条边是不是割边
int find(int x) { return x==fa[x]? x : fa[x]=find(fa[x]); }
void init()
{
    mm = cur = 0;
    memset(head, -1, sizeof head);
    for (int i=1;i<=n;i++) fa[i]=i;
    memset(dfn, 0, sizeof dfn);
    dep[0] = 0;
    memset(bridge, 0, sizeof bridge);

}
void dfs(int u, int fa)
{
    dfn[u] = low[u] = ++cur;
    dep[u] = dep[p[u]] + 1;
    for (int i=head[u]; ~i; i=e[i].next)
    {
        int v = e[i].to;
        if (v == fa) continue;
        if (dfn[v] == 0) {
            p[v] = u;
            dfs(v, u);
            low[u] = min(low[u], low[v]);
            if (low[v] > dfn[u] ) {
                cnt ++;
                bridge[v] = 1;
            }
        }
        else low[u] = min(low[u], dfn[v]);
    }
}
void LCA(int u, int v)
{
    if (dep[u] < dep[v]) swap(u, v);
    while (dep[u] > dep[v]) {
        if (bridge[u]) cnt--, bridge[u] = 0;
        u = p[u];
    }
    while (u - v) {
        if (bridge[u]) cnt--, bridge[u] = 0;
        if (bridge[v]) cnt--, bridge[v] = 0;
        u = p[u], v = p[v];
    }
}
int main()
{
    int ca = 1;
    while (scanf("%d%d", &n, &m) != EOF && n) {
        init();
        for (int i=0;i<m;i++) {
            int u, v;
            scanf("%d%d", &u, &v);
            add(u, v); add(v, u);
        }
        dfs(1, 0);
      /**  for (int i=1;i<=n;i++) {
            printf("dep[%d]=%d ",i,dep[i]);
            printf("p[%d]=%d ", i, p[i]);
            printf("bridge[%d]=%d\n", i, bridge[i]);
        } */
        scanf("%d", &Q);
        printf("Case %d:\n", ca++);
        for (int i=0;i<Q;i++) {
            int u, v;
            scanf("%d%d", &u, &v);
            LCA(u, v);
            printf("%d\n", cnt);
        }
        putchar(10);
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值